...and, true to form, within hours of reporting the issue, Wolfgang has delivered a fix for me to test - and it works!

I understand that it may be another 24hours or so before he gets around to uploading the fixed version to the original site.

Thank you WL!
M.

On 29/01/2018 08:42, Martyn Hill wrote:
Hi WL!

Yes - that was just my typo :-)


Martyn Hill
Sent from my mobile - please excuse spelling errors...

------------------------------------------------------------------------
On 29 Jan 2018 07:31, Wolf via Ql-Users <ql-users@lists.q-v-d.com> wrote:

sorry, this was meant for Martyn

On 29/01/2018 07:25, Wolf via Ql-Users wrote:
>
> Hi Martyn,
>
> thanks for pointing this out, I'll have a look.
>
> I presume that the difference between "targetPth$" and "targetPath$"
> below is just a typo here.
>
> Wolfgang
>
>
> On 28/01/2018 18:20, Martyn Hill via Ql-Users wrote:
>> Hi everyone
>>
>> Thanks to Wolfgang for his work on porting the WIN driver to QDOS and
>> merging with the SDC driver.
>>
>> As a result, I am now able to mount a number of .WIN container files
>> as WIN1_, WIN2_ etc and in the process, ease the transfer of files
>> from QPC to my QL(s).
>>
>> Loving it!
>>
>> One curiosity that I have spotted which worked as expected with the
>> original QubIDE/SDC driver but now throws an error under WIN/SDC is
>> use of RENAME. I've also posted this to the QL Forum, but as I
>> understand WL tends to hang-out here more than there, I'm posting to
>> this list as well:
>>
>> I'm running Minerva v1.98 on this QL, with the WIN/SDC driver burnt in
>> to the usual 16k ROM slot at 0c000.
>> Using my home-brew file-transfer app, I moved a file over to the QL,
>> as I do all the time from QPC. The app captures the file-fragments via
>> the SERial port in to a temporary file and, once the transfer is
>> complete, renames the tmp file to its final resting place on the SD
>> Card, with a given name.
>> The following worked fine under QubIDE/SDC, but errors-out with the
>> WIN/SDC driver (all else being equal):
>>
>>    RENAME tmpFile$ TO targetPth$ & fileName$
>>
>> The variables in question in this case were:
>>
>>    tmpFile$ = 'sdc1_tmp_1801281611'
>>    targetPath$ & fileName$ = 'sdc1_RMS_RMS_v4t4k_exe'
>>
>> The first 'RMS_' in the target file-path is a hard directory on SDC1_.
>> A WIN_USE 'sdc' appears in my Boot file, prior to running this app.
>> The error reported under WIN/SDC is 'bad name' and appears the same
>> whether using RENAME from the command line with explicit names in
>> place of the variables and even trying WREN in place of RENAME.
>> I can COPY the tmp file to its new name without problem (i.e.
>> replacing RENAME with COPY and keeping the rest as-is.) I can then
>> delete the original file manually as well.
>> When using WREN, the expected 'Do you want to copy xxx to yyy' prompt
>> appears and the error appears only after accepting with 'Y'.
>>
>> Any thoughts?
>> _______________________________________________
>> QL-Users Mailing List
> _______________________________________________
> QL-Users Mailing List
_______________________________________________
QL-Users Mailing List

--
"There are 10 types of people in this world. Those who understand binary and those 
who don't."

_______________________________________________
QL-Users Mailing List

Reply via email to