On Tue, 12 May 2020 07:34:08 +0200, Fabrizio Diversi via Ql-Users wrote:

> I am in the middle of multiple tests with CF/IDE and SD/IDE readers with 
> different type/size of CF and SD
> Few words about the 2 machine I am using :
> - Q40 with 1 IDE controller card with primary channel (master/slave) and 
> secondary (master/slave) on the same Card so in total 4 IDE devices:

Wow, you are lucky to have one of those !... They were pretty rare, even
back in the 90s, when the ISA bus was reigning in PCs. I never could get
my hands on any in France, and I did search a lot !

> as primary master I have a classic 80 GB IDE HD (2 atari partition), as 
> slave I have a CDROM. On the secondary channel as a master I have an 
> IDE/CF adapter. (StarTech 3.5 Drive Bay IDE to single CF SSD adapter 
> card reader). The second ISA slot is occupied by ethernet card. SMSQ/E 
> 2.92 on rom, then I load newer SMSQ/E (3.36) from primary master disk. 
> All the different combination of CF/SD I use on the StarTech are fine. 
> The system is working well and stable . Q40 is very tolerant with any 
> CF/SD reader I tried to used: I also replaced main primary (master) 
> classic 80 GB with a single SD reader (Kalea Informatique - Adapteur 
> Convertisseur IDE 3.5 40 pin vers SD Card) and also everything works 
> fine.....

Which makes me wonder whether this could be a problem with the IDE
controller on the ISA card, since it is this controller that "speaks"
with the IDE devices... Yours could be of better quality, or have a
wider range/more tolerant timings than mine...

I might give a try with another multi I/O card, and see if I get better
results with it.

So far, whichever CF Card I plugged into the passive CF-Card to IDE
adapter failed with I/O errors and lost interrupts reported by Linux
and corrupted data when using them under SMSQ/E.

I also received and tried with these two items in chain:
1.- IDE to SATA adapter:
2.- SATA to SDHC card adapter:

Here again, a total failure... Note that the IDE to SATA adapter
works just fine under Linux when a SATA HD is plugged in it, but
causes immediate crash under SMSQ/E as soon as I try to access the
HD in any way (even for reading a single sector).
Truth to be told, the ATA driver is very loosely (with regards to the
ATA protocol) implemented in SMSQ/E (I know first hand, for when I
wrote the ATAPI CD-ROM driver for the Q60, I came across problems due
to failures to respect the DRQ and BUSY bits by the ATA driver of
SMSQ/E, and I had to recourse to slower transfer methods in atomic
(supervisor only) mode in my own driver to avoid data corruptions and

I returned #2 to Amazon, and kept #1 (I'll use it for the PC in which
sits my QXL).

> - Q60: SMSQ/E 2.98 on Rom, 2 IDE cards ESIO v2.1, no ethernet. I had 
> also in the past a 2 slot ISA riser card to use the 2 IDE controller at 
> the same time with ethernet card (used with linux Shoestring), but at 
> the moment I removed the riser card (and linux) and I use the 2 IDE 
> cards in the single ISA slotᅵ with no Ethernet.

An ISA riser/extender would be a nice thing to have... Sadly, they seem
to sell at deliriously high prices, when you can find one on Internet.

> as slave I have a toshiba 4GB SD inserted into a passive CF2SD adapter
> type II (K  komputer K Bay).

Passive ?... I doubt it... SD cards got a serial interface, while CF
cards got a parallel one (IDE-compatible).

I could not find the "F2SD adapter type II K  komputer K Bay" adapter
on Internet. Probably not sold any more... :-/


QL-Users Mailing List

Reply via email to