Which program are you using to login? Webmail, or Thunderbird?

Is this an issue using Submission or IMAP?

What version of qmt are you using (Post output)?

# yum list | grep "\.qt."


On 11/13/2017 10:25 PM, Alexander Fordyce wrote:
yes, dovecot, as installed by instructions for CentOS 7 on qmailtoaster.com <http://qmailtoaster.com> page..  but it appears to be failing at the vpopmail level.  Restarted dovecot, no luck, still can't log in.  An example on the command-line...

# /home/vpopmail/bin/vchangepw
Please enter the email address:
  [ I enter "a...@axdev.net <mailto:a...@axdev.net>" ]
Enter old password:
  [ I copy and paste pw_clear_passwd value for pw_name = alex in vpopmail.axdev_net table ]
Error: authentication failed!


On Nov 13, 2017, at 8:50 PM, Eric Broch <ebr...@whitehorsetc.com <mailto:ebr...@whitehorsetc.com>> wrote:

Hi Alexander,

Is this Dovecot/IMAP?

If so on one occasion a restart of dovecot solved the issue. Also, I've removed the digest-md5 and cram-md5 from the dovecot configuration (auth_mechanisms = plain login) and used the same for the squirremail (/etc/squirrelmail/config.php: $imap_auth_mech = 'login';) and roundcube (/etc/roundcubemail/config.inc.php: $config['imap_auth_type'] = PLAIN;) webmail.


On 11/13/2017 8:33 PM, Alexander Fordyce wrote:
hello... I've been running a qmail toaster on CentOS 5 for a while now... works great, thanks for all your efforts!

I'm in the process of updating my hosting and deploying a new toaster on CentOS 7, specifically a DigitalOcean droplet running CentOS 7.4.1708.  Install went smoothly... output looks good with all services [ok].

Problem is... email users can't log in.  Everything appears to be working, all the programs run, but vpopmail never successfully authenticates, even when I know the password is right.  (I've checked the vpopmail database and verified the pw_clear_passwd column in the user's record).  when I run the vchangepw program from the command line and enter the user's old password, I get "Error: authentication failed!".

Not sure how to debug this... it's just a silent failure.  Have you come across this before?  Would this question be better asked on the mailing list?  I'd rather not subscribe to another list, but if it'll help, then ok.

Thanks in advance for any thoughts...

// - - - - - - - -
var AF = {
nm: 'Alexander Fordyce',
em: { h: 'axolo...@gmail.com <mailto:axolo...@gmail.com>', w: 'a...@xylosystems.com <mailto:a...@xylosystems.com>' },
ph: { mobile: '310-403-2427' },
  im: { skype: 'afordyce' }};
// - - - - - - - -

Eric Broch
White Horse Technical Consulting (WHTC)

Eric Broch
White Horse Technical Consulting (WHTC)

Reply via email to