Angus - I would be very cautious about switching if you've been using the non-mysql (cdb) version of the qmail toaster and you have many domains on the mailserver. You'll have to run a bunch of scripts to convert vpasswd and the dot-qmail forwards to the mysql format. And each domain has to be handled individually. I did this conversion with a mailserver with 150 domains and it took several days.

The good news is that Eric Broch recently put together a CDB version of the QMT 7 and I just finished converting a mailserver with 20 domains. It went much faster. I was able to tar-zip and dump in the entire /home/vpopmail/domains directory. Of course I had to update things in the /var/qmail/control and /users directories and setup some symlinks to handle changed locations. I'm still standing by and listening for user comments but it seems to be working very well.


Next, I plan to tackle two old qmail servers with over a 1000 domains each.

Jeff

On 2/15/2018 9:31 AM, Gary Bowling wrote:


For what it's worth, I was in the same boat last year and made the decision to move it to a new server. Set up a new CentOS 7 box as a virtual server at linode. Which was very painless. The install of the toaster on that box was a breeze, the guys have done a great job of supplying us with RPMs and scripts to get it done easily.


Moving over all the old mail was likewise very easy and just worked. I rsync'd from the old box to the new. The tricky part is cutting the users over. You need to set your DNS ttl to something really low (I first set mine to 4 hours, then to 1 minute the day of the cutover). That makes your mx and A records move very quickly. At cut time, change your dns, do a final rsync of all the old mail, make sure you're ownership and permissions are all right and you're done.


The transition was much smoother and easier than I had thought and everything worked like a charm.


So while it's not what you're looking for in terms of a short term fix. I do encourage you to take the plunge and move it. It's really not that bad and will clean up your entire environment.


Gary


On 2/15/2018 9:16 AM, Angus McIntyre wrote:
I'm running a fairly ancient qmail (netqmail-1.0.5, according to the manual) on CentOS 5, and I'm starting to get bitten with increasing frequency by the 'CNAME lookup failed temporarily' bug.

I urgently need to build a new host with an up-to-date OS and the latest version of qmail and move everything over, but I don't have the time to do that right now. I'm very hesitant to screw with this particular configuration (which is a mess) in case I bring everything crashing down around my ears.

So the question is, is there any easy (temporary) fix for this issue?

Thanks,

Angus

---------------------------------------------------------------------
To unsubscribe, e-mail: qmailtoaster-list-unsubscr...@qmailtoaster.com
For additional commands, e-mail: qmailtoaster-list-h...@qmailtoaster.com



--------------------------------------------------------------------- To unsubscribe, e-mail: qmailtoaster-list-unsubscr...@qmailtoaster.com For additional commands, e-mail: qmailtoaster-list-h...@qmailtoaster.com

Reply via email to