I'd REALLY be surprised if there were a problem.

On 10/3/2018 8:02 PM, Eric Broch wrote:

Try the CLI commands I sent. There can be issues with the configuration of squirrelmail and roundcube.

IMAP:

# openssl s_client -crlf -connect localhost:993

imap> tag login u...@domain.tld $userpassword


Submission:

# cd /usr/local/bin
# wget http://www.jetmore.org/john/code/swaks/latest/swaks
# chown root.root swaks
# chmod +x swaks

# swaks --to some...@remotedomain.tld --from u...@domain.tld --server $yourqmthost --port 587 --ehlo test -tls --auth login --auth-user u...@domain.tld --auth-password $userpassword


On 10/3/2018 7:45 PM, Andrew Swartz wrote:
Eric,

On Centos7 QMT:

I just created a new user account and set the password to '0123456789'.
Then I used your SQL command to set pw_clear_passwd to null.
Then I viewed the table to confirm it was empty (it was).
Then I tried to log in to Squirrelmail using password '0123456789':
Login failed.
Then I used your SQL command to reset pw_clear_passwd back to '0123456789'.
Then I tried to log in to Squirrelmail using password '0123456789':
success.

This seems different from your experience.

This sucks because it seems to mean no easy fix for this problem.


-Andy




On 10/3/2018 4:24 PM, Eric Broch wrote:
I've been contacted by someone who removed the clear text password from
an account and had issued logging into Dovecot even after a restart. The
fix of course is to reset the password with /home/vpopmail/bin/vpasswd.
Does anyone else want to confirm/refute my findings that w/o the clear
text password Dovecot will work?


--
Eric Broch
White Horse Technical Consulting (WHTC)

--
Eric Broch
White Horse Technical Consulting (WHTC)

Reply via email to