I just found out what happens:

The default ~/vpopmail/domains/yourdomain/.qmail-default file contains:

| /home/vpopmail/bin/vdelivermail '' bounce-no-mailbox

and the QmailAdmin vacation message works.
When you install and configure Dovecot and Sieve you have to change it to:

|/var/qmail/bin/preline -f /usr/libexec/dovecot/deliver -d $EXT@$USER -o postmaster_address=postmaster@yourdomain

and then the filters works.

So it's one or another I guess.
The filters are a lot more useful and that rule does the job, thanks for the tip.

btw: I turned the file .qmail-default immutable using chattr because QmailAdmin change it when you configure a catchall account.

Em 24/01/2019 15:58, Remo Mattei escreveu:
so here is what I did on mine to make the vacation working:

I have the password which resets the password in case the user wants to change it and that works ok unless you are using php7.x
(have not had time to debug that on that server running php 7 yet)

I have implemented managesieve plugin which user can set up an responder setting like this: create a new filter, select matching any of the following rules: then select to: is equal to your email

select reply with message

That does exactly what qmailadmin autoresponder action does.

Hopefully that helps.


    On Thursday, Jan 24, 2019 at 09:52, Leonardo Porto
    <leonardo.po...@iw.net.br <mailto:leonardo.po...@iw.net.br>> wrote:

    Hi everyone,

    I tried qmailadmin plugin but it doesn't work for me because it
    shows password and vacation message tabs in english even though my
    qmailadmin works in portuguese.
    So I'm working with password plugin and sql driver anyway.

    I found out vacation message is not working, I'm configuring it
    via QmailAdmin and the files seems ok:

    # ll /home/vpopmail/domains/iwtelecom.com.br/fulano/.qmail
    -rw------- 1 vpopmail vchkpw 207 Jan 24 15:31
    /home/vpopmail/domains/iwtelecom.com.br/fulano/.qmail # cat
    /home/vpopmail/domains/iwtelecom.com.br/fulano/Maildir/ |
    /usr/bin/autorespond 86400 3

    # ll
    -rw------- 1 vpopmail vchkpw 55 Jan 24 15:31
    /home/vpopmail/domains/iwtelecom.com.br/fulano/vacation/message #
    From: ful...@iwtelecom.com.br Subject: ausente

    No idea why yet.

    Em 23/01/2019 09:03, Leonardo Porto escreveu:

    Eric, sorry I did not express myself right, at the time I
    installed the old server I did not know how to do that, but now I
    saw it in that link you shared, thank you.

    I will use it but also want to test qmailadmin driver to see that
    it does and I share here.


    Em 22/01/2019 19:16, Eric Broch escreveu:

    2nd to last post:

    $rcmail_config['password_driver'] = 'sql';
    $rcmail_config['password_db_dsn'] =
    $domain = split("@",$emailuser);
    $dom_table = str_replace(".","_",$domain[1]);
    $rcmail_config['password_query'] = "UPDATE $dom_table SET
    pw_passwd=%c, pw_clear_passwd=%p WHERE pw_name=%l LIMIT 1";

    On 1/22/2019 1:43 PM, Leonardo Porto wrote:


    I use that in the old server but I did not know how to convert
    the "." into "_" then I fixed the domain name.
    I considered use it again but I can not remember how I got the
    vpopmail user's password in mysql or if I simply changed it.
    Can I change its password? I mean, will something stop working
    if I change it?

    Em 22/01/2019 13:01, Eric Broch escreveu:

    Here's on using mysql driver roundcube and account for our '_'
    in the domain name:


    On 1/22/2019 7:55 AM, Leonardo - IW Telecom wrote:

    Yeah I saw about it too but I did not try yet... I will try
    both and post the instructions.


    Em 22/01/2019 12:15, Eric Broch escreveu:

    Here's another plugin that I've found, it logs into qmailadmin:


    On 1/22/2019 6:59 AM, Leonardo - IW Telecom wrote:


    I found the same page and I am thinking to do exactly you said.
    Do you use roundcube or recommend another driver for
    password plugin?


    Em 22/01/2019 11:37, Eric Broch escreveu:


    I've never used vpopmaild, but...Have a look here:


    I think you can tailor the location of the run script to
    match the current qmail configuration in /var/qmail/supervise/


    On 1/22/2019 6:17 AM, Leonardo Porto wrote:

    Hi everyone,

    I am using Roundcube with my new qmailtoaster centos7
    installation. But I did not installed it using yum, I
    downloaded it from roundcube website and run installation
    script, I guess it is the same result.
    I trying to use the password plugin, it seems its default
    db driver does not work with qmail/vpopmail, so I tryed
    I run vpopmaild in command line using tcpserver and
    succefully changed the password in roundcube - I could
    see it working in command line.
    Now I suppose I have to create supervise files for
    vpopmaild... is that the usual method? Or you guys use
    something else?


    -- Eric Broch White Horse Technical Consulting (WHTC)
    -- Eric Broch White Horse Technical Consulting (WHTC)
    -- Eric Broch White Horse Technical Consulting (WHTC)
    -- Eric Broch White Horse Technical Consulting (WHTC)

Reply via email to