Kent Olsson schrieb:
I would like to add one more property called 'stepValue' in this class, then it would cover the the need of QxSlider and QxProgressBar, including QxSpinner as from before, I am finishing up right now.
I agree. Could be a nice addition.
Proposed name changes being more universal: min -> startValue max -> endValue
I like min and max more in general. The only problematic is QxProgressBar, as there does not exist any min or max values, just start and end values. As the user does not see this range manager directly I think it's OK to leave it the same way it is currently. Mean: Keeping "min" and "max"? Other opinions out there?
I've added the stepValue as "step" to our QxRangeManager.js. I've remove the modifier and check method as I don't think they are needed in this case like in the other ones.
Sebastian
the reason is stepping in both directions with a positive or negative step value Attaching proposed changes as a diff. Kent
------------------------------------------------------- This SF.Net email is sponsored by xPML, a groundbreaking scripting language that extends applications into web and mobile media. Attend the live webcast and join the prime developer group breaking into this new coding territory! http://sel.as-us.falkag.net/sel?cmd=lnk&kid=110944&bid=241720&dat=121642 _______________________________________________ Qooxdoo-devel mailing list [email protected] https://lists.sourceforge.net/lists/listinfo/qooxdoo-devel
