On 19 Sep 2004, at 06:12, Michael Holzt wrote:
- a plugin check_relayclient which should be called as the very first one in rcpt-chain. It will always return DECLINED, but will set transaction->relaying if either $ENV{RELAYCLIENT} is set, or client ip appears in relayclients or morerelayclients.
- a plugin check_relayfinal which should be called as the last one in rcpt-chain. It will do the remaining parts of the old check_relay plugin.
Two comments:
1: Why call the first one in the rcpt chain at all? Just make it a connect plugin.
2: Why split into two plugins - just make it two hooks.
