Hash: SHA512

On 2016-07-06 00:04, Marco D'emet wrote:
> Hello,
> Recently I have installed Qubes-whonix. To begin with I had
> trouble updating dom0 and the VM templates, alongside this I had
> tor bootstrapping errors which highlighted an issue with not being
> able to download the meta packages for both whonix-gw and
> whonix-ws templates. I resolved this issue and lastly updated the
> fedora template VM. After reboot tor was then able to connect
> however in the system tray a new icon appeared with two desktops
> and a red cross square, hovering over it read  'Networking
> disabled'. What is this issue and how do I resolve it?
> Further details, When I right click the icon the prompt to 'enable 
> networking' is shaded out. When I click the 'about' prompt I get
> the window title '[sys-firewall] About NetworkManager Applet',
> inside it reads that it is NetworkManager Applet 1.0.10.

This is the NetworkManager applet running in sys-firewall. Normally,
sys-firewall is connected to sys-net for network access, and the
NetworkManager applet only runs in sys-net. (The situation can be
different if you're running things like VPN VMs, but we'll set those
aside here.)

In short: the NetworkManager applet shouldn't be visible in
sys-firewall in the first place, but it's not a big problem (just a
confusing one). There's normally a script that hides it, but in your
case, that's not working for some reason.

You should be able to kill the applet by opening a terminal in
sys-firewall, then running:

    $ sudo kill $(pidof nm-applet)

See this thread for a similar discussion:


> I have read many other discussions in this group and none have a 
> solution that works. I am very new so I apologise for not being
> able to provide more information. As an aside it would be helpful
> if in addition to helping me solve this problem I might also be
> directed to sources which will let me better learn how to
> understand and work with qubes.

The main sources are our documentation:


And our mailing lists:


> Lastly, I have tried updating all templates and dom0, as I said I 
> have tried the solutions found elsewhere regarding enabling 
> networkmanager.dispatcher. I have tried as much as I know or 
> understand. Looking forward to some resolution to diminish 
> frustrations of qubes.

So, are you still having problems updating dom0 and your templates? If
so, can you explain the problems?

- -- 
Andrew David Wong (Axon)
Community Manager, Qubes OS


You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to