Hello,

Following Qubes documentation on firewall 
https://www.qubes-os.org/doc/qubes-firewall/, I tried to put some basics 
iptables rules into /rw/config/rc.local in an AppVM but they don't persist 
after reboots :

iptables -F
iptables -P INPUT DROP
iptables -P OUTPUT ACCEPT
iptables -P FORWARD DROP
iptables -A INPUT -i lo -j ACCEPT
iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
iptables -A INPUT -p tcp --dport 80 -j ACCEPT
iptables -A INPUT -p tcp --dport 443 -j ACCEPT

When I type "sudo iptables -L", they don't appear after rebooting the VM, I 
have the same rules as before, it looks like the script isn't launched :( This 
is weird because the file is executable ! ("sudo chmod +x rc.local"). Also I 
tried to add sudo before every line but it didn't change the outcome.

Any suggestions are welcome !
Regards

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/96b14998-9514-4db5-b64e-d2ff9192b6eb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to