On Wednesday, 28 September 2016 19:35:44 UTC+10, johny...@sigaint.org  wrote:
> > Hi JJ,
> >
> > Did some more testing, you were right, I only have 3.
> 
> Hey, that's still pretty handy for separation.
> 
> In Qubes VM Manager, for a chosen VM, you *should* be able to pick a given
> PCI USB device and assign it.
 
Yup, I did that, and it fails everything, it says the vm already using it, but 
the vm isn't even on to start using it and so the vm it's assigned to can't 
start because it's using a device it's got assigned to it. weird.. lol


> Only having one USB bus myself, also used for root, I haven't tried this.
> 
> I have a USB PCI card I've been tempted to use for similar reasons.  But
> once again, it was given to me out of the blue, which doesn't put it in my
> "trusted hardware" chain.
> 
> Not that *any* use bus or device should ever be trusted, the main
> motivation for us stuffing them in a VM.  :)
 
It is annoying isn't it?


> > I have 2 bus's on the motherboard...
> > I plugged a USB drive into each set to find out which were which.
> >
> > But that doesn't explain why it isn't working when I even just attach my
> > USB3 card to the USBVM.
> >
> > That alone should work, but it doesn't.
> 
> Agreed, it should work, from my understanding.  You reboot after assigning
> things?
 
rebooted, rebuilt, checked it wasn't on any other guests..

> There's some protection about PCI devices not being allowed to go back to
> dom0 for reassignment after use, to protect against potentially
> compromised devices then touching dom0 (to DMA-attack away):
> 
> https://www.qubes-os.org/doc/user-faq/#i-assigned-a-pci-device-to-a-qube-then-unassigned-itshut-down-the-qube-why-isnt-the-device-available-in-dom0
> 
> Not sure if that's relevant or not.  I'm over my head with this, and just
> guessing, so I probably shouldn't be giving advice, lol.

Nope, that isn't relevant. Interesting, but not relevant. Thanks. :}


> > So this means I should be able to attach the USB3 card, and the 4 other
> > USB to the USBVM, leaving 2 attached to Dom0 for my use.
> 
> Makes sense to me.  (Again, getting those darn keyboard/mice off of USB
> and onto PS/2 certainly wouldn't hurt figuring things out.)
 
It wouldn't change anything. 
If I can't assign a PCI-e USB3 4 port card to the VM and have it start... Bit 
of a problem?


> > So why does it have the error?
> 
> dmesg have any hints?  (Or is that where the error messages your are
> seeing are coming from in the first place?)

No hints, no tips, no help button.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/9e623d1e-70ed-4511-888c-263947b401c1%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to