Marek Marczykowski-Górecki:
> On Tue, Oct 18, 2016 at 12:05:33PM +0000, Emil Cronjäger wrote:
> 
> 
>> Marek Marczykowski-Górecki:
>>> On Mon, Oct 17, 2016 at 11:08:35PM +0000, Emil Cronjäger wrote:
>>>
>>>
>>>> Marek Marczykowski-Górecki:
>>>>> On Mon, Oct 17, 2016 at 07:50:26PM +0000, Emil Cronjäger wrote:
>>>>> Take a look at those instructions (in order):
>>>>> https://www.qubes-os.org/doc/upgrade-to-r3.0/
>>>
>>>> That got me a shell in one of the two VM's - thanx! There were some
>>>> problems with the ip-commands though, but I managed to get the data out,
>>>> and put it into a fresh VM.
>>>
>>>> The other VM (also standalone), however, wont help me with a shell:
>>>
>>>>    connected to domain [domain-name]
>>>>    error: operation failed: PTY device is not yet assigned
>>>
>>>> I am not sure or how to determine it, but it *might* be a debian-based
>>>> VM, if that is to any help.
>>>
>>> Standalone (PV) VM, right? Or maybe some HVM?
> 
>> yes, standalone VM, no HVM.
> 
>>>> It is not crucial for me to get the VM up and running, but I need to get
>>>> data out of it somehow.
>>>
>>> If you just want the data, create new VM, start it, and then attach the
>>> old VM private.img and/or root.img to the new one as additional device:
>>>
>>> qvm-block --attach-file new-vm /var/lib/qubes/appvms/old-vm/private.img
> 
> Correction: prefix file path with "dom0:". But if you didn't get any
> error, it should be fine too...
> 
>> The command goes through without any errors, but the device doesnt show
>> up in new-vm. No changes in lsblk before/after.
>> I tried the --frontend=xvdi, also goes through with no problem, but
>> still no new device for me in new-vm. Does it hide somewhere special?
> 
> No, it should be there as /dev/xvdi... Anything in `dmesg` output in
> new-vm?
> 

It worked with the "dom0:" option, the device got mounted as /dev/xvdi
and all good. I mistakenly used prefix "old-vm:", thats why it did't
work. Thanks a lot, all solved.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/3977c91d-84b4-5632-58cc-f8f78a34cdf0%40riseup.net.
For more options, visit https://groups.google.com/d/optout.

Attachment: signature.asc
Description: OpenPGP digital signature

Reply via email to