I'm trying to upgrade from a standard Fedora 23 template to Fedora 24,
but when following the instructions here
https://www.qubes-os.org/doc/fedora-template-upgrade-23/, at step 3 I

  sudo dnf --releasever=24 distro-sync
     Last metadata expiration check: 0:02:17 ago on Sun Nov  6 14:06:43
     Error: package python3-dnf-plugins-qubes-hooks-3.1.18-1.fc23.x86_64
requires python(abi) = 3.4, but none of the providers can be installed.
     package qubes-gui-vm-3.1.7-1.fc23.x86_64 requires pulseaudio = 7.1,
but none of the providers can be installed.
     package xen-qubes-vm-2001:4.6.1-20.fc23.x86_64 requires xen-libs =
2001:4.6.1-20.fc23, but none of the providers can be installed.
     package qubes-core-vm-3.1.18-1.fc23.x86_64 requires
python3-dnf-plugins-qubes-hooks, but none of the providers can be installed.
     package qubes-core-vm-systemd-3.1.18-1.fc23.x86_64 requires
qubes-core-vm, but none of the providers can be installed
     (try to add '--allowerasing' to command line to replace conflicting

As suggested, I tried adding --allowerasing, but that didn't help as
then I got

       xen-libs.x86_64 4.6.3-6.fc24  xen-licenses.x86_64 4.6.3-6.fc24
     Traceback (most recent call last):
       File "/bin/dnf", line 58, in <module>
         main.user_main(sys.argv[1:], exit_code=True)
       File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 174,
in user_main
       File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 60, in
       File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 120,
in _main
       File "/usr/lib/python3.4/site-packages/dnf/cli/main.py", line 159,
in resolving
       File "/usr/lib/python3.4/site-packages/dnf/plugin.py", line 82, in fn
       File "/usr/lib/python3.4/site-packages/dnf/util.py", line 183, in
       File "/usr/lib/python3.4/site-packages/dnf-plugins/qubes-hooks.py",
line 40, in transaction
       File "/usr/lib/python3.4/site-packages/iniparse/compat.py", line
146, in getboolean
       File "/usr/lib/python3.4/site-packages/iniparse/compat.py", line
219, in get

I have python 3.4 installed, so I also tried

     alternatives --install /usr/bin/python python /usr/bin/python3 2
     alternatives --install /usr/bin/python python /usr/bin/python2 1

and then repeating the upgrade process above, but that didn't help either.

Can anyone offer any more suggestions as to what I could try.



You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to