Hello Marek,

I reformatted the disk and now the system is working after copying the correct 
xen.cfg file.

The issue that is left is now the correct setting of the boot option by the 
install process.


Best Regards,

Wim Vervoorn

Eltan B.V.
Ambachtstraat 23
5481 SM Schijndel
The Netherlands

T : +31-(0)73-594 46 64
E : wvervo...@eltan.com
W : http://www.eltan.com

"THIS MESSAGE CONTAINS CONFIDENTIAL INFORMATION. UNLESS YOU ARE THE INTENDED 
RECIPIENT OF THIS MESSAGE, ANY USE OF THIS MESSAGE IS STRICTLY PROHIBITED. IF 
YOU HAVE RECEIVED THIS MESSAGE IN ERROR, PLEASE IMMEDIATELY NOTIFY THE SENDER 
BY TELEPHONE +31-(0)73-5944664 OR REPLY EMAIL, AND IMMEDIATELY DELETE THIS 
MESSAGE AND ALL COPIES." 




-----Original Message-----
From: Marek Marczykowski-Górecki [mailto:marma...@invisiblethingslab.com] 
Sent: Wednesday, April 19, 2017 9:26 PM
To: Wim Vervoorn <wvervo...@eltan.com>
Cc: qubes-users <qubes-users@googlegroups.com>
Subject: Re: [qubes-users] UEFI installation issue

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

On Wed, Apr 19, 2017 at 09:21:10PM +0200, Marek Marczykowski-Górecki wrote:
> On Wed, Apr 19, 2017 at 02:07:37PM +0000, Wim Vervoorn wrote:
> > Hello Marek,
> > 
> > I also tried booting using the xen.cfg file.
> > 
> > As far as I can see the cfg file is OK but the qubes os still fails.
> > 
> > The there is no request for the password and so the volumes are not 
> > unlocked.
> > 
> > I added both the xen.cfg I am using and the log file.
> > 
> > FYI /dev/sda1 is the ESP, /dev/sda2 is /boot and /dev/sda3 is the 
> > LVM partition
> > 
> > When I am using the rescue mode the password is asked and all seems to be 
> > fine.
> 
> Looks like your system use different LV names and also have LUKS 
> applied to individual LVM volumes, not the whole LVM volume group.
> 
>     [    2.548486] dom0 dracut-initqueue[362]: inactive '/dev/qubes_dom0/00' 
> [20.00 GiB] inherit
>     [    2.548886] dom0 dracut-initqueue[362]: inactive '/dev/qubes_dom0/01' 
> [10.00 GiB] inherit
>     [    2.556716] dom0 dracut-initqueue[362]: File descriptor 98 
> (socket:[9738]) leaked on lvm
>     invocation. Parent PID 489: /bin/sh
>     [    2.557017] dom0 dracut-initqueue[362]: File descriptor 99 
> (socket:[9739]) leaked on lvm
>     invocation. Parent PID 489: /bin/sh
>     [    2.564504] dom0 dracut-initqueue[362]: Failed to find logical volume 
> "qubes_dom0/root"
>     [    2.572468] dom0 dracut-initqueue[362]: File descriptor 98 
> (socket:[9738]) leaked on lvm
>     invocation. Parent PID 489: /bin/sh
>     [    2.572874] dom0 dracut-initqueue[362]: File descriptor 99 
> (socket:[9739]) leaked on lvm
>     invocation. Parent PID 489: /bin/sh
>     [    2.580150] dom0 dracut-initqueue[362]: Failed to find logical volume 
> "qubes_dom0/swap"
> 
> Try using qubes_dom0/00 instead of qubes_dom0/root and qubes_dom0/01 
> instead of qubes_dom0/swap. Or the other way around. And also adjust 
> root= accordingly (may require using UUID=... notation, but I cannot 
> tell based on the above info, before decrypting it).

Based on installation log (the other email), I actually can tell you what to 
put in root= option: /dev/mapper/luks-298b7206-1b82-46c0-8c1a-2b27a02f2384

Anyway, this layout (LUKS over LVM, instead of LVM over LUKS) isn't the best 
idea. I suggest you reinstall and make sure to have the other one (which should 
be the default...).

- --
Best Regards,
Marek Marczykowski-Górecki
Invisible Things Lab
A: Because it messes up the order in which people normally read text.
Q: Why is top-posting such a bad thing?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2

iQEbBAEBCAAGBQJY97neAAoJENuP0xzK19cssfAH+NQmb0JoDPL0qR/Y6J4is0aT
0lR04AynMNz+41pX0KilORAd02lob9my/rTrriiL2k6pgMC5rnpgMTFBG9Y/J0NF
rDuyvyhPIw6A524dhG2nRZbqRb91oyS8z/TNgHeDdviWzT7Wt+FX+qXbvDlcJkdE
7JIEfzoAgWEeOtu0NUowQ3D1gX0AWVdCxykh/fYw4sUZuV1DXhdXLSYbGSrJrevn
KODd5au6oe0EWw+MzOzMqVSXKTxDVS2CHs71HN4YEvygXjCiqk9IOrqN702tUwmV
4MkS/QDV/EOscUVFMKttSLXM6hz8bOT44vjiFCiqknLZ90qDpE90duzkNflsgg==
=+OLV
-----END PGP SIGNATURE-----


-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/5e14db6ef4b4445d8de03a3e393de4de%40Eltsrv03.Eltan.local.
For more options, visit https://groups.google.com/d/optout.

Reply via email to