I've finally got Qubes 4.0-rc1 booted! I've got a couple questions.

Without the VM Manager, is there a GUI way to delete VMs? I know you can
run "qvm-remove" from a dom0 terminal.

Is there a GUI way to start VMs without actually opening an application
in them? (I often configure stuff to autostart when the VM is started.)

I'm also noticing some strange USB VM stuff. On this computer I've opted
to make sys-net both my netvm and usbvm, and I've confirmed that sys-net
has my USB controller PCI devices attached.

By default, my sys-net uses memory balancing, even though it has the
warning message, "Dynamic memory balancing can result in some devices
not working!" Should I turn off memory balancing?

The devices systray applet thing for me lists these devices:

sys-firewall:1-1 QEMU_QEMU_USB_Tablet_42
sys-net:2-7 8087_07dc
sys-net:2-8 SunplusIT_INC._Integrated_Camera
dom0:mic Microphone

What is this qemu thing in sys-firewall? When I run lsusb in
sys-firewall I see two devices, "Adomax Technology Co., Ltd" and "Linux
Foundation 1.1 root hub". I confirm that sys-firewall doesn't have any
USB controller PCI devices. But even weirder, when I boot a different
AppVM, like personal, lsusb shows me the same USB devices, but it
doesn't appear in the Qubes devices systray applet.

And finally, when I plug in a USB device, the systray applet doesn't
seem to see it. I plugged in a Yubikey, and when I run qvm-usb in dom0
it displays:

sys-net:2-1 Yubico_Yubikey_4_OTP+U2F+CCID

And running lsusb in sys-net displays it as well. But the devices
dropdown doesn't list this.

Also, I noticed that qrexec clients now require an extra step. If I run
"qvm-copy-to-vm work example.txt" in my personal AppVM, the dom0 window
that pops up asks me to select the target ("work", in this case) before
clicking OK to allow it. This seems fine to me, and in fact I like how
clear it's being, but "work" isn't pre-filled in, so I have to manually
select it, or type it, each time, instead of just pressing enter.


Finally, pro tip: In xfce, and especially in Qubes, I find pressing
Alt-F3 and typing the name of a program much quicker than using the
start menu. If I want to open Firefox in the personal AppVM, I type
"personal:" and it shows me all the menu entries for personal, and
"personal: f" is enough to select Firefox by pressing enter.

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/2dee2c30-c593-2824-5cc1-7b0b26a854da%40micahflee.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to