Dear all,
I have been using Qubes OS R3.2 for a while (and liking it a lot!) on my 
laptop. It has worked flawlessly for some time. However,network connection has 
started to completely stop working properly after suspension during the last 
couple of weeks

I have tried to reload my network adapter drivers on suspend/resume (even 
automatically, following instructions on, but it has not 
completely solved the problem.
Since I added the ath10k drivers to /rw/config/suspend-module-blacklist, I have 
now connectivity in sys-net after suspension, but not in other VMs.
After some trial-and-error, I found that in order to regain access to the 
internet after resume I need to:
1. disconnect every network from the network manager in sys-net
2. manually reconnect my firewall VM to sys-net by typing "qvm-prefs -s 
sys-firewall netvm sys-net" in a Dom0 terminal
3. reconnect to my wifi in sys-net

It is not an enormous problem, nevertheless it is annoying.
Is someone else experiencing this issue? Does someone know what could be the 
root cause and how to properly fix it once and for all?
Thank you in advance.

L. G.

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To post to this group, send email to
To view this discussion on the web visit
For more options, visit

Reply via email to