Hash: SHA256

I'm having a difficult time attempting an EFI install of 
Qubes-R4.0-rc2-x86_64.iso across 4 different machines and 3 different USB 
sticks made by various procedures.

* Installing to an Asmedia USB3 device (all systems detect as HDD)
* Must use EFI installation

On all of the following, I have used 3 different USB sticks made by various 
procedures (Rufus in Windows on a USB2, dd in OSX and Etcher in OSX on two USB3 
sticks).  Also, I downloaded the ISO 3 different times and verified its PGP 
signature each time.  All USB sticks act exactly the same, except for on my 
Lenovo Helix: the Helix doesn't have proper EFI init that I've experienced with 
other installations.

I am attempting to install Qubes on an M.2 SSD via an Asmedia USB3 enclosure 
from all of the machines below.  This has worked flawless for Windows 10, 
Ubuntu 16.04 and ArchLinux installations as it is detected as a HDD.

Macbook Pro Retina mid-2014
- --
I get the first initial boot menu, asking to install with testing.

Selecting any option flashes the Xen boot for a microsecond, and returns back 
to the menu.

iMac 27" 5k late-2015
- --
Upon selecting Test installation media and install, it shows the Xen EFI boot - 
and freezes the system right there.  IOW, one more step than the Macbook Pro 

Lenovo Helix (1st gen)
- --
I already have Qubes R3.2 on this device.

The installer is not recognized from any of the Qubes 4.0 rc2 USB sticks under 

It shows and loads under Legacy; but, I require it to be EFI for the various 
machines I'll be booting in going forward (namely, some UP boards that only 
have EFI bios options).

(Desktop) Asus Rampage IV Black Edition
- --
Saved the best for last.  And by "best" meaning the most inconsistent issues.  
This is my high end gaming desktop, dual Titans, overclocked, water cooled, etc.

For the record, I have been running Windows 8.1, 10 and Arch Linux for the past 
4 years on this system (mostly Arch) with about 20 test installations over and 
over using several high end devices.  I know this system very well, and is 
extremely stable under Linux kernel as well as Windows with zero instability.  
Though, I have never tried FreeBSD kernels before.

I get various results using the same USB stick over and over.  I have removed 
all overclocking with various results.  "Various" results meaning I cannot 
reproduce the same error or condition all of the time.

Most common result:

When Anaconda starts, it flashes a graphic background with a "Progress" bar 
that slowly moves across the bottom for about 30s - and freezes the entire 
system, forcing a power off with power button 4s.

This screen does not show under normal installation.

Serious bug in the Installer:

Whenever the system freezes from one of the various issues, most of the time it 
marks the USB3 device as "Dirty" - before it even gets to any installation 
screen!  Worse off, it does this to my Arch and Ubuntu installs on the local 
SSDs!  I've since disconnected the internal HDDs, but it still marks dirty the 
USB3 I am installing to.  I usually have to remove it, and format it in another 
machine, between installation attempts.

Occasional Progress:

Sometimes, the system will get past the Xen and Anaconda init and actually load 
the Installation menu!  Where it asks for options for installing, encrypt disk, 
and starts installing!

But when it gets to this point, which I have only made it to twice, it has hard 
locked the system with the progress bar pretty close to the end running some 
script.  I didn't write the script name down, but I will next time.

If anyone has any advice, please let me know.  If Qubes 4.0 RTM will have a lot 
of installer fixes, I may just wait for that.



You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to