Hi,

so far it was easy to install and run Qubes OS 4.0 RC3 (and RC2) on this
hardware - as long as I keep boot mode on "Legacy Only".

However, the TPM chip on this hardware works in UEFI boot mode only; and
even with secureboot disabled and CSM support enabled, I can't get Qubes OS
to boot in UEFI mode:
- The installer doesn't run in UEFI mode (I get text mode grub, but
whatever i select simply does nothing and returns to grub)
- If I turn UEFI mode on after installing Qubes OS, I don't even get grub.
- I tried the UEFI troubleshooting guide to no avail, although I was unable
to run efibootmgr directly while in legacy boot mode ("EFI variables are
not supported on this system") so in order to run efibootmgr, i booted a
separate Fedora 26 Live image which does boot in UEFI mode. However, even
with updated records, the result is the same: selecting those options from
the UEFI boot menu simply makes the screen flicker once and then i'm back
in the UEFI boot menu.
- I tried copying the EFI and CFG file to /EFU/BOOT and renaming them to
BOOTX64.EFI and .CFG, and also created new entries with efibootmgr for
this, again without success.


I also tried installing Qubes OS 3.2 on this system which didn't work and
initial troubleshooting failed; but I'd like to concentrate my efforts on
making this work for Qubes 4.0 so i didn't spend too much time on getting
Qubes OS 3.2 on the T470.

Any hints about troubleshooting the UEFI boot option are appreciated; i can
also provide more exact details about what i already tried. Given the specs
of this machine, I'm really determined to not give up easily.

For now, I'll test other functionality in legacy mode only.

Cheers,
-joe

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/CAJmbC%3DEVMcAMKEXLGPooXa-kQt7_vuUDigozex%2Bq4iUSARykoQ%40mail.gmail.com.
For more options, visit https://groups.google.com/d/optout.

Attachment: Qubes-HCL-LENOVO-20HDCTO1WW-20171129-163138.yml
Description: application/yaml

Attachment: Qubes-HCL-LENOVO-20HDCTO1WW-20171129-163138.cpio.gz
Description: GNU Zip compressed data

Reply via email to