On Fri, December 22, 2017 1:33 pm, 'awokd' via qubes-users wrote:
> On Wed, December 20, 2017 11:51 pm, 'awokd' via qubes-users wrote:
>> On Wed, December 20, 2017 10:22 pm, Marek Marczykowski-Górecki wrote:
>>> Try building ISO based on example-configs/qubes-os-3.2.conf, with
>>> changed:
>>> DISTS_VM = fc26 stretch
>>> BRANCH_linux_kernel = stable-4.9
>>> And adjusted qubes-src/installer-qubes-os/conf/comps-qubes.xml for
>>> qubes-template-fedora-26 and qubes-template-debian-9 (simply modify
>>> existing entries to updated versions).

Finally got it. Build321.html are the steps I followed; bold where I
customized with line numbers on the file edits. BRANCH_linux_kernel =
stable-4.9 was already set. Had to add a line in
qubes-src/template-whonix/builder.conf for the current TBB version or that
template failed to build.

Installed in MBR mode on an AMD laptop. Installer warned it was a
pre-release/testing version. Ran into this bug 
but the workaround still worked. Had the same bug when I installed
official 3.2 on this laptop before. Got a "default-template fedora-23 does
not exist" when I first tried to install the default qubes so edited a
couple more qubes-src files to change the default to 26. Rebuilt
installer-qubes-os and the iso and then they installed.

The Stretch template was a lot easier to build this time than when I did
it a year or so ago! However, it's MIA from my install. I see a 583MB
qubes-template-stretch-4.0.0-201712222308.noarch.rpm in
qubes-src/linux-template-builder/rpm/noarch but it didn't get installed
with the others in there. Do I also need to edit some of the comps.xml
under linux-yum?

Hypervisor command line is just "placeholder"; this caused dom0 to consume
most of my RAM.

Good news is dom0 and the qubes are all on Linux
4.9.56-21.pvops.qubes.x86_64. Haven't done any testing past that. Will try
install on a UEFI Intel later.

For future reference, is it possible to "make -j4 qubes", and/or to make
each component in the order given in "make help" instead of my all or
nothing approach? Also, should I open a qubes-issue to track this build?

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.
Qubes 3.2 build 22Dec2017


sudo qubes-dom0-update qubes-template-fedora-25

[from https://www.qubes-os.org/doc/building-archlinux-template/]

Create standalone appVM from fedora 25 template named dev25
Set private storage to 60000MB, more if additional templates beyond default list
Increase CPU and RAM, disable memory balancing as desired


sudo dnf upgrade
sudo reboot
sudo dnf install git createrepo rpm-build make wget rpmdevtools dialog rpm-sign gnupg dpkg-dev debootstrap python2-sh

gpg --keyserver pgp.mit.edu --recv-keys 0xDDFA1A3E36879494
Verify its fingerprint, set as ‘trusted’. This is described here https://www.qubes-os.org/doc/VerifyingSignatures.
        gpg --edit-key 0x36879494
wget https://keys.qubes-os.org/keys/qubes-developers-keys.asc
gpg --import qubes-developers-keys.asc
gpg --keyserver pgp.mit.edu --recv-keys 916B8D99C38EAF5E8ADC7A2A8D66066A2EEACCDA

git clone git://github.com/QubesOS/qubes-builder.git qubes-builder
mkdir qubes-builder/keyrings
mkdir qubes-builder/keyrings/git
cp .gnupg/pubring.gpg qubes-builder/keyrings/git/
cp .gnupg/trustdb.gpg qubes-builder/keyrings/git/
cd qubes-builder
git tag -v `git describe`

gedit example-configs/qubes-os-r3.2.conf
	13: DISTS_VM = fc26 stretch

        Select 3.2
        No for a full build
        Select builder-fedora, builder-debian, template-whonix, mgmt-salt
        Y to download
        Select fc26, stretch, whonix-gateway, whonix-workstation

make install-deps
make get-sources

gedit qubes-src/installer-qubes-os/conf/comps-qubes.xml
        1164: <packagereq type="mandatory">qubes-template-fedora-26</packagereq>
        1174: <id>debian-9</id>
        1175: <name>Debian 9 (stretch) template</name>
        1179: <packagereq>qubes-template-debian-9</packagereq>
        1211: <groupid default='true'>debian-9</groupid>
gedit qubes-src/template-whonix/builder.conf
        22: WHONIX_TBB_VERSION ?= 7.0.11
gedit qubes-src/installer-qubes-os/qubes-anaconda-addon/firstboot-qubes-text
	107: qubes-prefs --set default-template 'fedora-26'
gedit qubes-src/installer-qubes-os/qubes-anaconda-addon/org_qubes_os_initial_setup/gui/spokes/qubes_os.py
	230: self.default_template = 'fedora-26'

make qubes
make iso

Reply via email to