I am working with a Lenovo X1 Carbon 5th Generation with following settings 

Boot support enabled for UEFI/Legacy (Both) in BIOS
VT-d = Enabled
Secure Boot = Disabled

The laptop has a pre-installed windows OS on it. I have installed Arch as 
multiboot and that is working.

Then, I tried Qubes installation. I followed all the steps in Lenovo Thinkpad 
Troubleshooting Guide (https://www.qubes-os.org/doc/thinkpad-troubleshooting/) 
and successfully installed it.

I did a manual partition and assigned following mount points during 
/boot            - Not Encrypted
/boot/efi        - Not Encrypted
/var             - Encrypted
/home            - Encrypted
swap             - Encrypted
/                - Encrypted

Installation was successful.

But, the grub menu still only shows Arch and Windows. I tried scanning the 
volumes to update grub from inside Arch but it could not find entries for Qubes 
(LVM issue??)

However, BIOS bootloader menu has an entry for Qubes alongside with Arch and 
Windows. When I chose Qubes there, screen flickers and it returns to the 
Bootloader menu. It behaves as if that boot option didn't even work.

I have tried going "Legacy" in boot removing UEFI support completely. Even that 
didn't work. All troubleshooting guides / multiboot guides start from editing 
grub entries. Since I can't even reach Qubes grub entries, I can't follow any 
of them.

Any pointers, please?

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to