On Tuesday, 23 January 2018 17:36:00 UTC, Krišjānis Gross  wrote:
> Hi, 
> I am trying to build a custom installation .iso. I have an issue that I have 
> purchased a new set of hardware that does not work with the current builds of 
> qubes. I am trying to build the most updated version with hope that it could 
> work. 
> I am running a Fedora linux and trying to build with these instructions: 
> https://www.qubes-os.org/doc/building-archlinux-template/
> I use the ./setup to create the installation configuration. 
> make install-deps goes fine.
> make get-sources goes smooth as well
> but I get an error when running the mage qubes command.
> Here is what I get:
> [krish@localhost qubes-builder]$ make qubes
> Currently installed dependencies:
> git-2.14.3-2.fc27.x86_64
> rpmdevtools-8.10-3.fc27.noarch
> rpm-build-4.14.0-2.fc27.x86_64
> createrepo-0.10.3-12.fc27.noarch
> debootstrap-1.0.92-1.fc27.noarch
> dpkg-dev-1.18.24-3.fc27.noarch
> python2-sh-1.12.14-2.fc27.noarch
> dialog-1.3-10.20170509.fc27.x86_64
> dpkg-dev-1.18.24-3.fc27.noarch
> debootstrap-1.0.92-1.fc27.noarch
> PyYAML-3.12-5.fc27.x86_64
> make[1]: Entering directory '/home/krish/qubes-builder'
> -> Preparing fc25 build environment
> -> Initializing RPM database...
> -> Retreiving core RPM packages...
> -> Verifying signatures...
> Filename: 
> /home/krish/qubes-builder/cache/fc25/base_rpms/acl-2.2.52-13.fc25.x86_64.rpm 
> is not signed.  Exiting!
> make[1]: *** 
> [/home/krish/qubes-builder/qubes-src/builder-fedora/Makefile.fedora:86: 
> /home/krish/qubes-builder/chroot-fc25/home/user/.prepared_base] Error 1
> make[1]: Leaving directory '/home/krish/qubes-builder'
> make: *** [Makefile:224: vmm-xen-dom0] Error 1
> Does anyone has an idea of what I do wrong or how to resolve this? 
> I have attached the builder.conf file that I have.

> Maybe the downloaded rpm is wrong? Did you try to remove it from cache 
and force it to download again? 

Yes, I tried the whole process multiple times. 
 - Tried cleaning the qubes-builder/cache folder. 
 - Tried other versions of fedora and got similar error. e.g. starting with 

> Also, did you download the keys and mark as trusted, or did .setup do it 
> for you? See the first few steps here: 
> https://www.qubes-os.org/doc/building-archlinux-template/ 
> There's a rumor rc4 may be out soon. 

Yes, I did that and I think that I did it correctly. Could post more details if 
you think this could be the root cause.

looking forward for the RC4 :)

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
For more options, visit https://groups.google.com/d/optout.

Reply via email to