On Sat, Feb 17, 2018 at 07:54:17AM -0800, snowboard...@gmail.com wrote:
> running qubes 3.2
> 
> I am following default instructions from Archlinux.Tried to build template 
> for trusty.
> 
> I cloned the default repo.
> 
> there is a problem with python2 because in fedora 23 there is no such 
> package. I had to manually edit and put python-sh in Makefile, builder.conf 
> and setup script. After that everything seems to be working fine but it 
> crashes during make qubes-vm with this message:
> 
> ln -s ../../bin/qrexec-client-vm 
> /home/user/qubes-src/core-agent-linux/debian/tmp/usr/lib/qubes/qrexec_client_vm
> install qrexec-fork-server 
> /home/user/qubes-src/core-agent-linux/debian/tmp/usr/bin
> install qubes-rpc-multiplexer 
> /home/user/qubes-src/core-agent-linux/debian/tmp/usr/lib/qubes
> make[2]: Leaving directory `/home/user/qubes-src/core-agent-linux/qrexec'
> make[1]: Leaving directory `/home/user/qubes-src/core-agent-linux'
>    dh_install
> cp: cannot stat 
> 'debian/tmp/lib/systemd/system/netfilter-persistent.service.d/30_qubes.conf': 
> No such file or directory
> dh_install: cp -a 
> debian/tmp/lib/systemd/system/netfilter-persistent.service.d/30_qubes.conf 
> debian/qubes-core-agent//lib/systemd/system/netfilter-persistent.service.d/ 
> returned exit code 1
> make: *** [binary] Error 2
> dpkg-buildpackage: error: fakeroot debian/rules binary gave error exit status 
> 2
> /home/user/qubes-builder/qubes-src/builder-debian/Makefile.qubuntu:200: 
> recipe for target 'dist-package' failed
> make[2]: *** [dist-package] Error 2
> Makefile.generic:156: recipe for target 'packages' failed
> make[1]: *** [packages] Error 1
> Makefile:212: recipe for target 'core-agent-linux-vm' failed
> 
> 
> Why is it so difficult to build a default template? Should be working oob 
> right?
> 
It should indeed work oob.
Truth is that I only really support 1 LTS and the latest Ubuntu
version. I havent built Trusty for some time, and it's difficult to keep
it up to date with the changing code base.The right thing to do would be
to take it out the build configs.
If there's some specific reason that you need trusty, and you cant
install as HVM, I'll take a quick look and see if the build issues can
be fixed. It may be simple.
Can you let me know?

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/20180218163858.zneywsadxvgi3fbf%40thirdeyesecurity.org.
For more options, visit https://groups.google.com/d/optout.

Reply via email to