Qubes 3.2

Last night I was updating dom0, but in the middle of the update I accidentally 
hit some keys on the keyboard, which I now in hindsight realize must have 
included Ctrl-Z.

At that point the update just stopped and froze at item 13/42 which just so 
happened to be qubes kernel 4.14.67-1.

I tried to exit the console but was told there were stopped jobs (update was 
backgrounded no doubt). Not knowing any better in the moment, I force restarted 
my computer and retried the dom0 update. 

It did successfully re-download and install the new kernel, but also said that 
was the only new thing to be installed, and did not make any attempt to pick up 
where it left off and download the other remaining items, 14-through-42 of 42. 
I did qubes-dom0-update a few more times with the same result - it says there's 
nothing new available. The system seemed to think and act as though the other 
packages had all already been updated/installed, even though they hadn't.

The next time I tried a reboot, the boot-up failed with a kernel panic and went 
into a boot loop. Choosing advanced options and using the older kernel 
4.14.57-1 allowed me to boot up, and here I am.

So what should I do from here? Is there any way to force the dom0 update to 
refresh or redo or reset, so that it gets everything it needs to function 
correctly with the newer kernel? I'm not sure what command to use or what 
file(s) to edit in order to forcibly instruct it to re-download and install all 
possible missing packages, when the normal qubes-dom0-update insists there's no 
update available. Right now I have a half-broken system and am not sure how to 
proceed.

Any help would be very greatly appreciated..

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To post to this group, send email to qubes-users@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/0d3a9655-c941-47f4-82ad-6c987e37d8d3%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to