On 2019-12-18 07:57, Stumpy wrote:
Last night I noticed that I was not able to start an appvm via dom0 (qvm-run appvm programname) so then tried to start another app in another appvm, nothing. I had a bunch of things open still from earlier in the afternoon so figured I needed to reboot, did, and still nothing, except I dont have any previous apps open up so my system is barely usable.

When i try to run an app, say from the xfce menu (or directly from the dom0 terminal) I get the little pop up that the VM is starting, and it shows up in zentop and the qubes manager, but no app. I tried to start apps from the right click "run" option in the qubes manager but nothing, doesnt matter if the appvm is already running or not.

The only thing i have done in dom0 in terms of "messing around" was to modify the sudo vi /etc/qubes/quid.conf so that one of my appvms would open w/o a border (which I since undid in attempts to get things working) i cant think of anything else i have done in dom0?

This is killing me as I am not working on my work/win comp :( so any help would really really really be appreciated. Please let me know if there are any logs or something i should be posting?

This sounds very similar to a problem I have been having (at home and at work), only your issue sounds like a much worse case of it.

Ref: Qubes 4.0.1, Fedora-30 template

When I come into work in the morning, or upon booting my workstation at home, if I launch an app in a non-running VM (sometimes subsequent re-launches of a VM) the app I used to initiate that VM does not come up. The pop-up message of the starting VM appears, then nothing. The VM gets started and the disk is whirring away, but the app never appears. If I launch the same app again sometimes both instances of that app appear one right after they other. Between those two invocations I might even wait until all the disk activity settles down and everything works fine.

If for instance I use Qubes Manager to "update qube" the window almost never comes up the first time. The second time it will. If I start the template first and then select "update qube" it almost always comes up correctly, unless something is chewing up all the CPU or hitting the disk pretty hard.

My issue seems to be related to too much activity of the AppVM's services creating enough lag to the system that the qrexec either times out or gets slowed down to the point of not completing the launching of the app. This is frustrating because after the first launch it seems to work better, so testing of why it isn't starting clearly needs to be planned in advance. Perhaps some resources get cached in memory the firt time so it starts that VM quicker, and thus the qrexec doesn't time out?

I would suggest turning on the "Run in debug mode" option in the Qubes Manager's AppVM configuration so you can collect better logging information and see if that tells you anything. That is what I am planning to do tomorrow morning before launching anything. I had just turned it on for one VM this morning that sometimes acts up, and wouldn't you know it, it has not repeated that problem launching that VM the second time. Maybe tomorrow, or if I leave the machine alone for a while I might get it to repeat again. I think I will make a habit of turning on the debugging before launching any new VM's just in case I can catch it in the act of not acting properly.

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to