Tae Hwan Kim:
> Hi.
> I am trying to connect my android phone to my work vm in qubes os. So I 
> tried this.
> 
> 1. Changed AppVM(work) to HVM because PVH mode no PCI passthrough which I 
> am trying to do.
> 2. 
> lsusb
> 
> Bus 001 Device 002: ID 1004:61f9 LG Electronics
> 3. And then I did 
> readlink  /sys/bus/usb/devices/usb1
> 
> and it returned
> ../../../devices/pci0000:00/0000:00:14.0/usb1
> 
> 4. finally
> qvm-pci attach --persistent work dom0:00_14.0

This looks valid.

> But it says "empty response" and doesn't work.
> I followed this step <https://www.qubes-os.org/doc/usb-devices/>.
> Am I doing right? In the result of lsusb says my usb connected in Bus 001 
> so I did 
> 
> readlink /sys/bus/usb/devices/usb1 instead of usb3(in document). Did I do it 
> correctly?
> 
Is your USB controller already assigned somewhere else, like sys-usb by
default? If so, you should try to assign just the USB device to your
work qube first instead of the controller with qvm-usb (see --help for
options). If you have and it isn't working, you might need to shutdown
sys-usb before you can re-assign a controller it is using. qvm-pci by
itself will show which devices are assigned to different qubes in the
USED BY column. You will often need to include the no-strict-reset
option with USB controllers.

-- 
- don't top post
Mailing list etiquette:
- trim quoted reply to only relevant portions
- when possible, copy and paste text instead of screenshots

-- 
You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/qubes-users/231e7292-59c0-7507-2731-16d653573665%40danwin1210.me.

Reply via email to