> On 7. Oct 2020, at 20:52, Stumpy stumpy-at-posteo.co wrote:
> On 2020-10-07 21:13, Stumpy wrote:
>> On 2020-10-06 19:12, Frank wrote:
>>>> On 6. Oct 2020, at 13:53, Stumpy stumpy-at-posteo.co wrote:
>>>> On 2020-10-06 10:46, Frank wrote:
>>>>>>>> On 5. Oct 2020, at 16:16, Stumpy stumpy-at-posteo.co wrote:
>>>>>>> My computer actiing strange like some appvms not opening so i
>>>>>>> decided to restart and restarted normally and booted back up fine
>>>>>>> except now i can hardly open anything. Appvms will not start, I
>>>>>>> tried to do a backup from dom0 term and that gave me an error, tried
>>>>>>> to run qubes-qube-manager and that gave me a similar error [1]...
>>>>>>> I'm at a loss. Of course I just finished doing some important work
>>>>>>> and didnt immediately backp (usually bkup weekly).
>>>>>>> I am not thrilled about reinstalling but can do it, but really
>>>>>>> really really want to back up my appvms before nuking everything. If
>>>>>>> i cant use the regular backup is there a way i can just copy things?
>>>>>>> I think I can still mount an external drive...
>>>>>> This should give you all the information necessary to get your data
>>>>>> saved:
>>>>>> https://www.qubes-os.org/doc/mount-from-other-os/
>>>>>> Regards, Frank
>>>>> Thank you, I didnt notice that.
>>>>> I dont suppose you have any thoughts on the error that seems to be 
>>>>> borking my system?
>>> I fear I don’t... but isn’t errno 2 something like „file not found“?
>>> So it smells like dom0 is having problems getting everything mounted
>>> where it belongs - either because the file system is screwed or LVM is
>>> having some problems.
>>> In any case, I’d be backing up whatever I could get my hands on and
>>> then reinstall...
>> Ok so on the mount from other os page its not totally clear for me.
>> I do have a barebones qubes system on another computer (laptop), so
>> would/should I take my ssd from my desktop connect it (have an adapter
>> cable) to my laptop then "pass" the whole disk to an isolated appvm?
>> If yes, then,,, what is meant by passing the disk to an appvm
>> (copying?) and when it says isolated appvm does that just mean, in my
>> case, an appvm on my laptop? Lastly, as my laptop drive is smaller
>> than my desktop drive, would I be able to selectively copy/mount to my
>> laptop appvm or would I need to go another route?
> btw, on my desktop, I am still able to access a dom0 terminal and can connect 
> to an external drive (I think), so can i just cp the appvms to an external 
> drive and then extract the contents of the critical appvms?

Well in that case you can do the following in a dom0 terminal (assuming the 
name of your AppVM you want to get files from is my-appvm):

# create a mount point to access the disk:

sudo mkdir /mnt/private

# make the private volume of the appvm accessible !!! notice the doubling of 
the dash in the AppVMs name (naturally not applicable if your AppVMs name does 
not contain a dash) !!!

sudo losetup -f —show /dev/mapper/qubes_dom0-vm—my—appvm—private

# use the loop device the last command printed to the screen (i.e. /dev/loop2) 
to mount the AppVMs private volume

sudo mount /dev/loop2 /mnt/private

# now you should be able to copy whatever data you want to save

cp /mnt/private/home/user/* /some/place/save/

Hope that works out for you!

Regards, Frank

> Sorry, the mount from other os page is a bit over my head hence my attempting 
> to find options that I can understand :/

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to