I tried in a fresh vm:
user@my-new-qube:~$ qvm-connect-tcp 8332:bitcoind:8332
Binding TCP 'bitcoind:8332' to 'localhost:8332'...
user@my-new-qube:~$ telnet localhost 8332
Trying ::1...
Connected to localhost.
Escape character is '^]'.
Request refused
2021/06/09 17:50:53 socat[992] E waitpid(): child 993 exited with status 126
Connection closed by foreign host.

How would bitcoin core even know that I'm connecting from a different VM, if it 
should also be as if from localhost?

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Thursday, June 10th, 2021 at 12:09 AM, keyandthegate 
<keyandtheg...@protonmail.com> wrote:

> Hi, I'm following the instructions here: 
> https://github.com/qubenix/qubes-whonix-bitcoin/blob/master/1_joinmarket.md
> After I run "qvm-connect-tcp 8332:bitcoind:8332" in the joinmarket vm
> "telnet localhost 8332" works from bitcoind vm, but does not work from the 
> joinmarket vm, where it says "Connection closed by foreign host."
> I tried adding this to my bitcoin config:
> rpcbind=
> rpcallowip=
> rpcbind=bitcoind
> and then running "sudo systemctl restart bitcoind"
> after reading:
> https://bitcoin.stackexchange.com/questions/87943/unable-to-bind-any-endpoint-for-rpc-server
> but it didn't help
> Is there anywhere I can find a working example of using qvm-connect-tcp to 
> connect to bitcoin core RPC server from another vm?

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to