The controller (PCIe based) works fine with other OS installations (tested with both the Debian-based Pop!OS and Arch Linux) on the exact same machine and hardware, this makes me believe that it isn't the controllers fault. When passing the controller to a Qube, either Windows 10 or the sys-usb Qube it doesn't work.

In Windows it is recognized but doesn't work. If you look inside of Device Manager it sometimes says that the device driver failed to load because "This device is not present" (Code 24) but other times it fails with other exit codes (for example code 10).

In sys-usb it gets recognized by lspci but it doesn't work and I do not know what logs to look at so unfortunately I cannot provide more information there.

To pass the controller I have tried to simply use the GUI with and without the "no-strict reset" option. I have also blacklisted it at boot time (as you have to do with for example a GPU), by adding "rd.qubes_hide_pci=05:00.0" (Where 05:00.0 is the controller) to my boot parameters (and of course then running grub2-mkconfig -o /boot/efi/EFI/qubes/grub.cfg) and then tried both with and without "no-strict reset". None have worked except from when I yesterday blacklisted the controller, and selected "no-strict reset" then booted my Windows 10 HVM. It worked for a couple hours and I tough I had solved it but when I then turned the Qube off and today wanted to start it again, without changing anything, it didn't work. After that I tried everything again and nothing works. Even after reboots.

I really do not know were to go from here, so any help would be appreciated!

You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
To view this discussion on the web visit

Reply via email to