On Monday, 18 April 2022 13:37:25 GMT Demi Marie Obenour wrote:
> On Mon, Apr 18, 2022 at 02:57:32AM +0000, Michał "rysiek" Woźniak wrote:
> > Hey all,
> > 
> > I am trying to get the nVidia binary driver to work in dom0. Using the
> > latest version of it (510.60.02) always ends up with this line in
> > `Xorg.0.log`,> 
> > followed by X crashing:
> > > Failed to allocate push buffer
> > 
> > Running `nvidia-smi` shows the card is available, kernel modules loaded; I
> > can get temperature readouts, for example.
> > 
> > Tried changing UEFI settings ("discrete" vs "hybrid" mode), tried fiddling
> > with kernel parameters (modesetting, iommu), to no avail.
> > 
> > Not sure what I could try next. Any ideas welcome!
> Have you considered using sys-gui-gpu instead? 

I have not, for a very specific reason: in the laptop in question, all external 
video outputs are hard-wired to the nvidia card. That is, I *cannot* use an 
external display *unless* I get the nvidia card to work, somehow.

I had *some* small progress: if I go the nouveau route (with 
nouveau.modeset=1), I get an external display recognized and configured in X 
now. I can move my mouse to it. I cannot display any actual windows on it.

> Binary drivers in dom0 are a bad idea, both from a security and reliability
> perspective. 

I am well aware of that. But as far as security is concerned, GPU passthrough 
has its own problems. It's turtles all the way down!

> In particular, dom0 has an old version of both X11 and Mesa, which may well
> be incompatible with the blob driver.

That's true. I am going to try some older ones. Already tried 495.46, got a 
different error:
> Failed to allocate shared surface

I guess I should try to figure out which binary driver was the newest when the 
dom0 versions of xorg and Mesa were released.

> Alternatively, if your computer has an integrated Intel GPU, you could
> use that. 

That's what I've been using, but that leaves me without the ability to use 
external displays.

> Nouveau might also be an option, if it supports your card.

It doesn't seem to (see above).


You received this message because you are subscribed to the Google Groups 
"qubes-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to qubes-users+unsubscr...@googlegroups.com.
To view this discussion on the web visit 

Reply via email to