While trying to test the use of an external editor, I tried commands
such as :edit-url. I got errors such as

    Error while spawning editor: The process failed to start.

I tried using different editors (visual or text based) running qutebrowser as

    EDITOR=/usr/bin/emacs qutebrowser

or

    VISUAL=/usr/bin/emacs qutebrowser

using other editors beyond emacs and the result was the same error. I
did check using a command such as

    :debug-pyeval os.environ["VISUAL"]

that the VISUAL, EDITOR and PATH environment variables were correctly
set and visible from qutebrowser. My editors run correctly from the
terminal. I can also run 

   :spawn emacs

and the editor is correctly started.

Any idea what can be wrong?

I'm running under debian/testing using xfce.

Best regards,
Luis


-- 

                                                                  o
W. Luis Mochán,                      | tel:(52)(777)329-1734     /<(*)
Instituto de Ciencias Físicas, UNAM  | fax:(52)(777)317-5388     `>/   /\
Apdo. Postal 48-3, 62251             |                           (*)/\/  \
Cuernavaca, Morelos, México          | moc...@fis.unam.mx   /\_/\__/
GPG: 791EB9EB, C949 3F81 6D9B 1191 9A16  C2DF 5F0A C52B 791E B9EB

Reply via email to