I tell to my students that it is very important (not only for legibility) to place spaces between operands. They have to write such a code like this:

if (x < -3) do_something

That way, there is no ambiguity. Don't you think it's important to write clear code, including by using spaces where it makes it easier to read,... and less ambiguous, as you just realize?

Best,

Philippe Grosjean

On 23/08/10 19:06, Davor Cubranic wrote:
On 2010-08-23, at 6:15 AM, Barry Rowlingson wrote:

On Sun, Aug 22, 2010 at 4:33 PM, ivo welch<ivo.we...@gmail.com>  wrote:
I have found that my students often make the mistake of
mixing up comparisons and assignments with negative numbers:

  if (x<-3) do_something;

If you tell your students not to use '<-' for assignment, then they
can't make this mistake, because = for assignment has additional
restrictions on it:

The students are trying to *compare* to a negative number, and trip on R's parsing of 
"<-". They could use '=' for assignment all they want (which I thought is being 
discouraged as a code style these days, BTW), and they'll still run into this problem.

Davor
______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel



______________________________________________
R-devel@r-project.org mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel

Reply via email to