Hello all,

In one of my packages, I have the following warning with R-devel, but no 
problems with R 2.1.0, or R patched:

** checking Rd \usage sections ... WARNING
Bad \usage lines found in documentation object 'guiStart':
   guiStart(gui = "\"

Functions with \usage entries need to have the appropriate \alias entries,
and all their arguments documented.
The \usage entries must correspond to syntactically valid R code.
See chapter 'Writing R documentation files' in manual 'Writing R
Extensions'.

my function is:

"guiStart" <-
function(gui = "\"%SciViews_Home%/bin/RConsole.exe\" -connect") {
    ....
}

and the way it is defined in \usage:
\usage{
   guiStart(gui = "\"%SciViews_Home%/bin/RConsole.exe\" -connect")
}

I am pretty sure it is a stupid error I made regarding \", or something 
similar. Could someone tell me what that stupid error really is?
Thanks.

Philippe

..............................................<}))><........
  ) ) ) ) )
( ( ( ( (    Prof. Philippe Grosjean
  ) ) ) ) )
( ( ( ( (    Numerical Ecology of Aquatic Systems
  ) ) ) ) )   Mons-Hainaut University, Pentagone (3D08)
( ( ( ( (    Academie Universitaire Wallonie-Bruxelles
  ) ) ) ) )   8, av du Champ de Mars, 7000 Mons, Belgium
( ( ( ( (
  ) ) ) ) )   phone: + 32.65.37.34.97, fax: + 32.65.37.30.54
( ( ( ( (    email: [EMAIL PROTECTED]
  ) ) ) ) )
( ( ( ( (    web:   http://www.umh.ac.be/~econum
  ) ) ) ) )          http://www.sciviews.org
( ( ( ( (
..............................................................

______________________________________________
R-devel@stat.math.ethz.ch mailing list
https://stat.ethz.ch/mailman/listinfo/r-devel

Reply via email to