Thanks to every one who contributed - there definitely isn't a consensus, but perhaps a slight preference towards number 3 (camelCase). I'm not sure yet if this beats out my personal preference for number 2.
Hadley On 2/25/07, hadley wickham <[EMAIL PROTECTED]> wrote: > What do you prefer/recommend for double-banger function names: > > 1 scale.colour > 2 scale_colour > 3 scaleColour > > 1 is more R-like, but conflicts with S3. 2 is a modern version of > number 1, but not many packages use it. Number 3 is more java-like. > (I like number 2 best) > > Any suggestions? > > Thanks, > > Hadley > ______________________________________________ [email protected] mailing list https://stat.ethz.ch/mailman/listinfo/r-help PLEASE do read the posting guide http://www.R-project.org/posting-guide.html and provide commented, minimal, self-contained, reproducible code.
