On 10/04/2016 05:54 PM, Rolf Turner wrote:

I previously sent a cri de coeur about this problem to the r-help list
but so far have not managed to extract a solution.  So I am trying here.
(Uh, Ubuntu *is* a "special instance" of Debian, isn't it?)

The problem is that I cannot install rgdal, and I need it.  Rather

I do:


and get the error message:

** testing if installed package can be loaded
Error in dyn.load(file, DLLpath = DLLpath, ...) :
  unable to load shared object '/home/rolf/Rlib/rgdal/libs/rgdal.so':
  /home/rolf/Rlib/rgdal/libs/rgdal.so: undefined symbol:
Error: loading failed
Execution halted

Since I (in my desperation) cross-posted to r-sig-debian and r-help, I am sending this "SOLVED" message to both lists.

The solution took a long while to find, but in the end it was very simple.

Quite a while back I was having problems with installing some package
(I *think* it was one of my own packages, hmm.discnp), and someone (the details are lost in the mists of time) advised me to create a directory ".R" in my home directory and in it place a file "Makevars" containing the lines:

FCFLAGS = -g -O2 -mtune=native -fbounds-check
FFLAGS = -g -O2 -mtune=native -fbounds-check

This solved the problem that I was having at that time. I had long forgotten the directory ".R" and *that* was what was causing the problem.

A *very* clever and knowledgeable young Linux whiz, who kindly agreed to help me with this problem, eventually tracked down the fact that it originated from ".R". When I removed ".R", the problem with rgdal (and
problems with several other packages, that subsequently surfaced) went away.

My system is now humming away smoothly.

Thanks to everyone who (futilely!) attempted to help me out.


Rolf Turner

Technical Editor ANZJS
Department of Statistics
University of Auckland
Phone: +64-9-373-7599 ext. 88276

R-SIG-Debian mailing list

Reply via email to