This mail consists of two parts. The first part is a potential bug report,
and the second more of a question, but both regards the combination of R and
data from SPSS/PASW.

*First part:*
I don´t know if this is a Mac specific bug, and I didn't find any obvious
reason for this behaviour in the read.spss-function - maybe it is one of
those 0.0-version bugs in PASW, but here goes:

I work with a dataset in SPSS format, and after installing PASW Statistics
18.0.0 for Mac, suddenly when I import the file by the following command:

data <- read.spss(file="thefile.sav", to.data.frame=TRUE, use.value.labels=

I get this response:

Warning message:
In read.spss(file = "thefile.sav", to.data.frame = TRUE,  :
  thefile.sav: Unrecognized record type 7, subtype 18 encountered in system

Most of the data seemed okay, I am not sure. Maybe the "subtype 18" is just
a coincidence? or maybe version 18 files are not supported by the
read.spss-function? But I tried saving the file as type SPSS 7.0 (in PASW
18), with the same response.

The warning message went away when I went back to PASW 17.0.2, and saved the
file from there before importing it (using the same command as above) in R.

*Second part:*
Is there a known incompatibility with scaled variables with labeled missing
values when importing from SPSS/PASW? When I tried importing such variables,
they were converted to "atomic" variables, and I weren't able to use them,
so I had to delete the missing value labels before importing the data in R.
Also - SPSS/PASW supports ranged missing values, but these doesn´t seem to
be recognized when importing data with the read.spss-function.


Peter Holme
Department of Political Science
University of Oslo
+47 920 42 782

        [[alternative HTML version deleted]]

R-SIG-Mac mailing list

Reply via email to