Hi Elizabeth,

I have submitted ape 5.0 on CRAN on 5 October but I'm still waiting for feedback. I suspect there are problems with reverse dependencies. In the meantime, I cleared the testing repositories thinking that CRAN would take the usual 1-2 days to publish the new version. Sorry for the confusion.

I have just uploaded a version 4.9 on the testing repos which is virtually identical to the version being examined by CRAN. I'll upload a Windows build in a few hours. The NEWS file on ape-package.ird.fr has been updated.

Best,

Emmanuel

Le 17/10/2017 à 12:11, Elizabeth Purdom a écrit :
Hello,

I currently have version 4.1 of ape installed on my computer (Mac OS X, R 
3.4.2) which appears to currently be the most up-to-date on CRAN. However, I am 
trying to get the testing version of ape, because I know that there have been 
changes made that I would like to take advantage of without waiting for them to 
show up on CRAN. I have tried using the commands on the website, and they do 
not show any new versions available. Specifically, using `old.packages`, 
nothing is returned:

old.packages(repos = "http://ape-package.ird.fr/";)
NULL

And trying to download anyway gets me an error:

download.packages("ape", ".", repos = "http://ape-package.ird.fr/";)
trying URL 'http://ape-package.ird.fr/src/contrib/ape_0.0.1.tar.gz'
Error in download.file(url, destfile, method, mode = "wb", ...) :
   cannot open URL 'http://ape-package.ird.fr/src/contrib/ape_0.0.1.tar.gz'
In addition: Warning message:
In download.file(url, destfile, method, mode = "wb", ...) :
   cannot open URL 'http://ape-package.ird.fr/src/contrib/ape_0.0.1.tar.gz': 
HTTP status was '404 Not Found'
Warning in download.packages("ape", ".", repos = "http://ape-package.ird.fr/";) :
   download of package ‘ape’ failed
      [,1] [,2]

This is presumably because http://ape-package.ird.fr/src/contrib/PACKAGES 
points to 0.0.1. I don’t immediately see an option to specify a version of the 
package (and indeed I don’t know what version I would put in). Do I need to be 
running a development version of R to get the newest versions of ape?

Thanks for any help,
Elizabeth Purdom

PS Here is my sessionInfo:

sessionInfo()
R version 3.4.2 (2017-09-28)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: OS X El Capitan 10.11.6

Matrix products: default
BLAS: 
/Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRblas.0.dylib
LAPACK: 
/Library/Frameworks/R.framework/Versions/3.4/Resources/lib/libRlapack.dylib

locale:
[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

other attached packages:
[1] BiocInstaller_1.26.1

loaded via a namespace (and not attached):
[1] compiler_3.4.2 tools_3.4.2

_______________________________________________
R-sig-phylo mailing list - R-sig-phylo@r-project.org
https://stat.ethz.ch/mailman/listinfo/r-sig-phylo
Searchable archive at http://www.mail-archive.com/r-sig-phylo@r-project.org/


_______________________________________________
R-sig-phylo mailing list - R-sig-phylo@r-project.org
https://stat.ethz.ch/mailman/listinfo/r-sig-phylo
Searchable archive at http://www.mail-archive.com/r-sig-phylo@r-project.org/

Reply via email to