This issue still exists on High Sierra and with Racket 6.11. I even see it 
happen on the non-nightly, stable builds. It's a bit of a hassle to have to 
do the drag-n-drop dance every single time I update Racket. I'm we would 
all appreciate having signed app bundles so that this problem goes away.

On Tuesday, October 18, 2016 at 10:04:48 AM UTC-4, Geoffrey Knauth wrote:
> On Tuesday, October 18, 2016 at 9:44:56 AM UTC-4, Matthew Flatt wrote:
> > Nightly builds are not currently signed, so Sierra doesn't like them.
> > 
> > Try this: Using Finder, drag the DrRacket icon out of its folder. Then
> > drag it back in place. Then try double-clicking DrRacket. (Yes, that's
> > weird.)
> Ha!  Fighting weirdness with weirdness.  I got it to work, but it was 
> slightly more complicated:
> When I dragged the icon out of its folder to the Desktop, it created a 
> link instead.  I got rid of the link on the Desktop, since that wasn't what 
> I was aiming for.
> When I dragged the icon *up*, to the level above where it was, and then 
> back in its folder, those moves worked (as moves), but double-clicking 
> didn't work.  However, right-menu Open did work, and after that 
> double-click worked, and having it in my dock and clicking on it worked.
> So I'm all set.  Thanks!

You received this message because you are subscribed to the Google Groups 
"Racket Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
For more options, visit

Reply via email to