Sean Cribbs wrote:
> Shane,
> 
> Try removing all extensions from loading while doing this.  Edit the
> appropriate line of config/environment.rb to read:
> 
> config.extensions = []
> 
> Also, comment out the line in config/environments/development.rb that
> starts 'config.breakpoint_server'
> 
> # config.breakpoint_server = ....
> 
> That will get rid of the warning.  Then when those tasks have been run,
> restore your config.extensions line.
> 
> Sean



I followed the directions... Side note, my environments.rb file had the 
config.extensions line already commented out but I continued on anyway 
with your suggestions? It looks like the migration worked but when I 
tried to start the server I got this error:

=> Booting Mongrel (use 'script/server webrick' to force WEBrick)
=> Rails application starting on http://0.0.0.0:7000
=> Call with -d to detach
=> Ctrl-C to shutdown server
** Starting Mongrel listening at 0.0.0.0:7000
** Starting Rails with production environment...
Could not load extension from file: shards_extension.
#<NameError: uninitialized constant ShardsExtension>
Exiting
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:266:in
 
`load_missing_constant': uninitialized constant ApplicationController 
(NameError)
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:453:in
 
`const_missing'
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:465:in
 
`const_missing'
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/app/controllers/admin/abstract_model_controller.rb:1
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in `require'
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:496:in
 
`require'
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:342:in
 
`new_constants_in'
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/activesupport/lib/active_support/dependencies.rb:496:in
 
`require'
   ... 50 levels...
  from 
/Library/Ruby/Gems/1.8/gems/radiant-0.6.7/vendor/rails/railties/lib/commands/server.rb:39
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in 
`gem_original_require'
  from /Library/Ruby/Site/1.8/rubygems/custom_require.rb:27:in `require'
  from script/server:3


It wasn't really mentioned but since 0.6.7 has shards baked in do I 
still need shards installed to run reorder?


shane
-- 
Posted via http://www.ruby-forum.com/.
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to