I saw an error like this when trying to upgrade an app from rails 1.2.6 to rails 2.0 and it had to do (in my case) with any method that used url_options_for (if I recall the name of the method correctly). I don't know if that helps, but do you have some setup where a different version of rails is being loaded than the one provided with the Radiant gem?

-Jim

On Jun 27, 2008, at 5:37 PM, Alex Wayne wrote:

Turns our I am getting this when rendering ANY snippet, and ANY context :(

-Alex
http://beautifulpixel.com

On Jun 27, 2008, at 2:24 PM, Alex Wayne wrote:

I am trying to render a blog post snippet iteratively on a blog index page. When when I view the blog page, I get "wrong number of arguments (2 for 1)"

First off, any way I can get info about that error? Radiant seems to trap all errors from bubbling up, and they don't even appear in my log file.

Here's the markup in question
http://www.pastie.org/223693

Also, I just discovered if I render a blank snippet, it still errors. It's as if <r:snippet> inside <r:children:each> just crashes. Any ideas?


-Alex
http://beautifulpixel.com

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to