Weird. Your CSS headers look right. Your CSS validates (well enough, anyway). Stranger still, if I download it using firefox and run it locally, all's well.

My best guess is the @import line.  What happens if you remove it?

-Chris

Marshal Linfoot wrote:
Hi all.

I'm having a problem with the SnS extension and need some help.
Radiant 0.6.7 (gem) and Styles and Scripts extension v0.6. The
extension installed without any errors, I can access the CSS and JS
tabs, and have created a stylesheet called "elastic".

In the layout for my pages I have: <r:stylesheet name="elastic"
as="link" media="screen" /> which renders as <link rel="stylesheet"
href="/css/elastic" type="text/css" media="screen" />. Looks okay to
me, but the page renders without the css being applied -- no styling.
The Radiant production log shows:

Processing SiteController#show_page (for 99.232.3.139 at 2008-07-23
14:58:33) [GET]
  Parameters: {"url"=>"/", "action"=>"show_page", "controller"=>"site"}
Completed in 0.19283 (5 reqs/sec) | DB: 0.00000 (0%) | 200 OK
[http://test.octopusgardenyoga.com/]

Processing SiteController#show_page (for 99.232.3.139 at 2008-07-23
14:58:34) [GET]
  Parameters: {"url"=>["css", "elastic"], "action"=>"show_page",
"controller"=>"site"}
Filter chain halted as
[#<ActionController::Filters::ClassMethods::SymbolFilter:0x2adc426c66d0
@filter=:parse_url_for_text_a
ssets>] rendered_or_redirected.
Completed in 0.01643 (60 reqs/sec) | DB: 0.00000 (0%) | 304 Not
Modified [http://test.octopusgardenyoga.com/css/elastic]

I have no idea why the css isn't being applied. Tried naming it
"elastic.css", same results. Tried <r:stylesheet name="elastic"
as="inline"  /> and it places the css inline as expected, but no
styling.

Thanks for any help. I'm eager to use this extension for all the good
reasons Chris mentions in the README.

PS. You can see the rendered pages at http://test.octopusgardenyoga.com


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to