On Jul 23, 2008, at 5:22 PM, Tim Gossett wrote:

On Wed, Jul 23, 2008 at 11:10 AM, Marshal Linfoot <[EMAIL PROTECTED]>
wrote:


The Radiant production log shows:

Processing SiteController#show_page (for 99.232.3.139 at 2008-07-23
14:58:33) [GET]
Parameters: {"url"=>"/", "action"=>"show_page", "controller"=>"site"}
Completed in 0.19283 (5 reqs/sec) | DB: 0.00000 (0%) | 200 OK
[http://test.octopusgardenyoga.com/]

Processing SiteController#show_page (for 99.232.3.139 at 2008-07-23
14:58:34) [GET]
Parameters: {"url"=>["css", "elastic"], "action"=>"show_page",
"controller"=>"site"}
Filter chain halted as
[#<ActionController::Filters::ClassMethods::SymbolFilter: 0x2adc426c66d0
@filter=:parse_url_for_text_a
ssets>] rendered_or_redirected.
Completed in 0.01643 (60 reqs/sec) | DB: 0.00000 (0%) | 304 Not
Modified [http://test.octopusgardenyoga.com/css/elastic]

I have no idea why the css isn't being applied. Tried naming it
"elastic.css", same results. Tried <r:stylesheet name="elastic"
as="inline"  /> and it places the css inline as expected, but no
styling.

I think your problem is the first line:

@import url("gallery.css")

I don't think the SnS extension can handle SASS imports (because SASS looks for a .sass or .css file in the filesystem, not in the DB), so it passes the directive into the rendered stylesheet. Since @import is not valid CSS, your browser stops processing rules, and no styles get applied. You'll need to
add a <r:stylesheet /> tag for every stylesheet you want to use.

Maybe Chris is working on a way to include multiple stylesheets with one
tag. For now, though, you should use one tag per css file.



The other thing you need to check is that the header is being set correctly. SnS uses a config setting in the database for this, is should be set to text/css.

Strangely, the link you sent renders perfectly in Safari, though in FF it renders without css...

Keith

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to