Hello,

i know that other have post similar problems , but I can find a solution. I
am trying to install Radiant in the gs , but i get the following error after
trying to star it

application started, but pid file was not found, check 'mtr status'

I reinstalled the mongrel and rails gem and looked at the production log and
nothing . I fooudn some stuf fon my mongrel log and I think that is telling
me that the problem is with mysql. I know that the internal ruby-only
implemetation is not meant to work on prodcution mode,but I made sure that i
installed the the mysql gem form mediatemple the mogrel looks like this:

or info.
** Starting Mongrel listening at 0.0.0.0:2011
** Starting Rails with production environment...
/containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:471:in
`real_connect': Can't connect to MySQL server on 'internal-db.s#####.
gridserver.com' (111) (Mysql::Error)
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:471:in
`connect'
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:165:in
`initialize'
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:88:in
`new'
/containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/mysql_adapter.rb:88:in
`mysql_connection'
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:291:in
`send'
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:291:in
`connection='
containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:259:in
`retrieve_connection'
/containers/rails/radiant/vendor/radiant/vendor/rails/activerecord/lib/active_record/connection_adapters/abstract/connection_specification.rb:78:in
`connection'
     ... 52 levels...
data/rubygems/gems/gems/mongrel-1.1.5-x86-linux/bin/../lib/mongrel/command.rb:212:in
`run'
/data/rubygems/gems/gems/mongrel-1.1.5-x86-linux/bin/mongrel_rails:281
data/rubygems/gems/bin/mongrel_rails:19:in `load'
data/rubygems/gems/bin/mongrel_rails:19
** Daemonized, any open files are closed.  Look at log/mongrel.pid and
log/mongrel.log for info.

I also ran rail debugged to see of I would get anything else on the
mongrel_debug logs, but nothing come up on them so i guess there is
something wrong with MYsql and anyhelp would be apreciated it.
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to