Josh,

It doesn't like the temporary directory for some reason. Try setting the TEMP shell environment variable to something else, like C:\temp. In order to avoid messing up your Radiant project, script/extension does all of its checkout/unpack stuff in the temporary directory, and then copies the results to your project.

Sean

Josh Godsiff wrote:
Hi

I have a problem with script/extension not working on my installation of
Radiant

For example, trying to install the Gallery extension via this method yields
the following:

C:\www\rails_apps\radiant>ruby script/extension install gallery
The filename, directory name, or volume label syntax is incorrect.
c:/www/ruby/lib/ruby/1.8/fileutils.rb:1255:in `copy': unknown file type:
C:/User
s/silk/AppData/Local/Temp/gallery (RuntimeError)
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:451:in `copy_entry'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:1324:in `traverse'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:448:in `copy_entry'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:423:in `cp_r'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:1395:in
`fu_each_src_dest'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:1411:in
`fu_each_src_dest0'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:1393:in
`fu_each_src_dest'
        from c:/www/ruby/lib/ruby/1.8/fileutils.rb:422:in `cp_r'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:37:in `copy_to_vendor_extensions'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:31:in `install'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:81:in `install'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:10:in `install'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:231:in `initialize'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:193:in `new'
        from
c:/www/ruby/lib/ruby/gems/1.8/gems/radiant-0.6.9/lib/radiant/extens
ion/script.rb:193:in `execute'
        from script/extension:5


Does someone know what I might be doing wrong, or a way to fix this? I
managed to get the gallery installed using GIT, but I'd rather not do that
for every extension I want if there's an easier way.

My system/server is:
Windows Vista Ultimate (before anyone suggests I change OS, this is not an
option at present. If this computer liked Linux, it'd be running it
tomorrow).
Standard InstantRails server (Apache using Mongrel for Rails, w/MySQL
Database)
Radiant 0.6.9 standard installation.

Any help would be appreciated.


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to