I have an app that I tried to update from 0.6.7 to 0.6.9 and have run into a
couple of problems.

It started a bit like this. I ran "rake radiant:update" which seemed to
complete successfully. But when I tried to "rake db:migrate" I was greeted
with the error:
...
rake aborted!
undefined method `[]' for #<Enumerable::Enumerator:0x2329874>
...


So I searched around and saw what looked like a cure here (11th response):
http://groups.google.com/group/radiantcms-dev/browse_thread/thread/309b7516b2bb72f9?fwc=2
...
unless '1.9'.respond_to?(:force_encoding)
  String.class_eval do
    begin
      remove_method :chars
    rescue NameError
      # OK
    end
  end
end
...


Then I ran "rake db:migrate" the migration died when it got to the sessions
table with this error:
...
== 16 AddSessions: migrating
==================================================
-- create_table(:sessions)
rake aborted!
Mysql::Error: Table 'sessions' already exists: CREATE TABLE `sessions` (`id`
int(11) DEFAULT NULL auto_increment PRIMARY KEY, `session_id` varchar(255)
DEFAULT NULL, `data` text DEFAULT NULL, `updated_at` datetime DEFAULT NULL)
ENGINE=InnoDB

(See full trace by running task with --trace)
...


So I truncated the sessions table and the rake task completed successfully.
After that, "script/server" started the application with no problem. But I
discovered a new problem, my database had been wiped clean during the
process, so when I tried viewing the site at 127.0.0.1:3000 I was greeted
with a login screen.

I would really appreciate it if anybody who has run into similar problems
could describe what they did to get through all this.

My setup:

Ruby 1.8.7
Rails 2.2.2, 2.1.2   (tried both)
Radiant 0.6.9

Extensions:

Archive
Blog Tags
Comments
Copy Move
Markdown Filter
Page Attachments
Share Layouts
Subscriber Lists
Textile Filter
Wine Pairing Widget (custom extension)

On OSX 10.5, but the application originated in Ubuntu and was lovingly
transferred over to the mac. Everything worked perfectly when it was running
on radiant 0.6.7 in both OSX and Ubuntu.



Thanks,

Nate
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to