I've installed Radiant on Site 5, and everything worked just fine. I
needed to create a public service so I can access some info from my DB on
the pages created with radiant, so I created a controller, for an extension
I created,  (ProfesionsController) that rendered the info I needed.
Everything worked great in my local environment (running mongrel) and I
could happily access my service with '/profesions' without any problems. Now
when I added this service on my production environment I came with a
problem: I got HTTP 500 responses that said "Application Error, Rails
Application Failed to start properly". So I went to site 5 help desk. They
said that I had some permissions issues, and that I didn't have my app
configured to use fastcgi. So, I fixed the permission issues, and I
configured my .htaccess file to use fastcgi by adding the proper
RewriteRule. Then, I restarted the fastcgi by killing the dispatch.fcgi
process. Now my '/profesions' request works fine!, except that every other
request is sent to /admin/pages!!!. So now I'm unable to hit the home page
(or any page) that i created with Radiant!. So its like every url I try to
hit gets redirected to the Radiant Admin page. I checked the rails logs, and
this is what i get :

Processing SiteController#show_page (for at 2008-12-13
16:14:23) [GET]
  Parameters: {"action"=>"show_page", "url"=>["add-member-form"],
Redirected to http://animebar.com.mx/admin/login
Filter chain halted as
@filter=:authenticate>] rendered_or_redirected.
Completed in 0.00045 (2238 reqs/sec) | DB: 0.00000 (0%) | 302 Found [

Has anyone had a problem similar to this one ?

Thank you very much in advance,

Daniel Valencia
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to