I'm going to try to recreate the issue in a brand new installation, but my workaround was to modify gallery_item.rb like this:

  before_thumbnail_saved do |thumbnail|
    thumbnail.gallery_id = thumbnail.parent.gallery_id
  end

It doesn't seem too terribly ugly, but it does force an extra SQL call, so there's a performance hit.

Aloha a hui hou,
Ken
--
Ken Mayer / kma...@bitwrangler.com / 808-722-6142 / http://www.bitwrangler.com/


On Dec 22, 2008, at 10:24 PM, beddoes wrote:


Hi,

I am seeing the exact same issue with the latest version of both
attachment_fu and gallery, did you guys get anywhere on this one?.

Bradley


Andrea Franz-2 wrote:

On 15/dic/08, at 00:24, Ken Mayer <li...@bitwrangler.com> wrote:

Andrea,

Maybe it's me, but I'm looking at
http://github.com/technoweenie/attachment_fu/blame/master/lib/technoweenie/attachment_fu.rb

Line 284 is where they make the callback and it only passes in one
argument, "thumb"


I'll try asap, but with the version I use I receive 2 parameters. I'm
going to try the latest.

Is this a scoping issue?

Aloha a hui hou,
Ken
--
Ken Mayer / kma...@bitwrangler.com / 808-722-6142 /
http://www.bitwrangler.com/


On Dec 10, 2008, at 11:34 PM, Andrea Franz wrote:

On Thu, Dec 11, 2008 at 7:59 AM, Ken Mayer <li...@bitwrangler.com>
wrote:

I've been having trouble getting the gallery extension working.
This is a
brand new install, so perhaps it's a version compatibility issue.

After following the installation instructions, and creating my first
gallery, I tried uploading a single image (JPG). I got the
following error:

The error occurred while evaluating nil.gallery_id=):
/vendor/extensions/gallery/app/models/gallery_item.rb:39


Here's the code in app/models/gallery_item.rb:38-40:

before_thumbnail_saved do |item, thumbnail|
thumbnail.gallery_id = item.gallery_id
end



I use the gallery_id on a thumbnail when I call
Gallery.clear_thumb. In that
method I remove all the thumbnails without removing original images.
Are you using the latest attachment_fu? I had some trouble with the
attachment_fu version. let me know.

--
Andrea Franz
http://gravityblast.com
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant



--
View this message in context: 
http://www.nabble.com/Trouble-getting-gallery-extension-running-tp20950393p21141084.html
Sent from the Radiant - User (New) mailing list archive at Nabble.com.

_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant


_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to