Sorry, my bad. I updated the tutorial a few months back, replacing the scaffolding (which was deprecated in Rails) with Radiant's own AbstractModelController. I made alterations to the tutorial after modifying my local copy of the LinkRoll controller, but I didn't try running through the tutorial from start to finish.

Having now followed through the tutorial, I found that the /admin/ links index page worked ok, but the /admin/links/new /edit and /remove pages threw a template not found exception. To fix this, I did the following:

* Rename links_controller to link_controller
* Update class Admin::LinksController to Admin::LinkController
* rename the directory /app/views/admin/links to /link
* finally, in the link_roll_extension.rb file, change the line:

    map.with_options(:controller => 'admin/links') do |link|


    map.with_options(:controller => 'admin/link') do |link|

I've updated the tutorial with these corrections. If anyone has the time to follow the steps from start to finish, I would be glad to hear whether or not it works for you.

Note that these modifications are only suitable if your extension is running on Radiant 0.6.9 or earlier. If you are running on 0.7 (which has not been released, at time of writing), then the modifications above are useless. The confusion stems from Radiant having defied a Rails convention: using plural names for controllers. (e.g. in 0.6.9, we have a snippet_controller). This has been fixed as part of the RESTful refactoring of Radiant for version 0.7. (in 0.7, we have a snippets_controller). Hopefully that will lead to less confusion in the future.


On 20 Jan 2009, at 08:43, Roman Marszalek wrote:

Hi All,

I've also tried this

1) from scratch on another machine. i.e. gem install radiant all the
way through to running the extension.

2) on my hosting account with Joyent on Radiant 0.6.8 and same error.

Can someone confirm that it works for them at least?



On Mon, Jan 19, 2009 at 5:20 PM, Roman Marszalek <> wrote:
Just to make sure I wasn't making any typos, I found the tutorial
extension on github

I donwloaded this and ran everything again and I get exactly the same
issue, i.e.

"Missing template admin/link/edit.html.erb in view path"

If anyone has any ideas that 'd be wonderful.



On Mon, Jan 19, 2009 at 3:59 PM, Roman Marszalek <> wrote:
I'd like to write my own custom tags. As a start I've been following
the following tutorial

When I enter the admin interface, go to the "Links" tab and the click
the "New" link I get the following message

"Template is missing

Missing template admin/link/edit.html.erb in view path
/Users/roman/work/custom_tags/vendor/extensions/link_roll/app/ views:/usr/local/lib/ruby/gems/1.8/gems/radiant-0.6.9/app/views"

I don't know why it's trying to go to admin/link/edit.html.erb rather
than admin/links/edit.html.erb

I've double-checked everything including the define_routes do |map|
bit in the main rb file.

Any ideas - I'm doing the tut with radiant 0.6.9


Roman Marszalek
Managing Director
mobile: +44 7786 262 002

telephone: 0800 345 7844 (+44 20 7014 3634)
Our lines are open from 9am to 6pm Monday to Friday

Doctor Logic Limited
Mac Support for London

* Dr Logic Backup *
Backup for Britain

* Dr Logic Training *
In partnership with Academy Class

Registered in England and Wales. Company No. 04947299.
Registered Office: 2nd Floor 145-157 St John Street, London EC1V 4PY
VAT Reg. No. GB848448189

Radiant mailing list

Radiant mailing list

Reply via email to