Sorry all if this is completely irrelevant to some, but I just
installed the latest Radiant gem for the first time today and was
surprised to find out I could even get the README/INSTALL to work! So
I just did a "personal patch" to the cucumber.rake file line # 4 in my
Radiant gem just inserting after the 'begin' line:

  gem 'cucumber', '0.3.104'
...etc. (nothing else changed)
and I was able to get the db:bootstrap to work fine.

It should really be gem 'cucumber', '< SOME_VERSION' where
SOME_VERSION should probably be 0.4.0 so that it works with 0.3.+, but
I'm a newbie to Radiant so I don't feel comfortable doing this. It
seems that 0.3.104 was the last < 0.4.0 and that's where Cucumber's
docs say "no mas" to the deprecated feature_pattern. In any event,
this "ugly" personal patch fixed it for me.

My Local cukes after downgrading:
$ sudo gem install cucumber --version '0.3.104'
$ gem list --local cucumber
cucumber (0.4.0.rc1, 0.3.104)

and then re-ran:
    rake development db:bootstrap
    $ ./script/server -e development

Saw my Radiant CMS.

Hope this helps the next poor soul!

On Sun, Nov 15, 2009 at 3:50 PM, Rob Levin <roblevinten...@gmail.com> wrote:
> I'm brand new, newbie, new guy, to Radiant and have installed the
> Radiant 0.8.1 gem. I tried to follow the INSTALL notes, google, etc.,
> but I get the following error because radiant 0.8.1 does not seem to
> work with cucumber-0.4.0.rc1:
>
> (in 
> /Users/roblevin/Desktop/Programming/Ruby/ruby_programs/rails/Radiants/radiant_test)
> rake aborted!
> undefined method `feature_pattern=' for #<Cucumber::Rake::Task:0x1b1d068>
> ...etc.
>
> I've seen some activity about this error in other posts, and see a
> ticket, but no real resolution. I don't want to uninstall cucumber
> 0.4.0.rc1 system-wide because I'm using this heavily with other
> applications and/or projects. Is there a workaround short of creating
> a patch for Radiant itself? Or is there such a patch already
> available? I would think that if there was a gem dependency, there
> would be a line somewhere in the source code like: gem 'cucumber', '<
> NON_WORKING_VERSION' Any help would be appreciated. Thanks.
>
_______________________________________________
Radiant mailing list
Post:   Radiant@radiantcms.org
Search: http://radiantcms.org/mailing-list/search/
Site:   http://lists.radiantcms.org/mailman/listinfo/radiant

Reply via email to