worked here with rake 0.8.7. may as well just change the version in the gemspec.

http://github.com/radiant/radiant/commit/7d0a0d2

On Wed, May 19, 2010 at 4:15 PM, D.Kreft <dkr...@gmail.com> wrote:
> Negative, Ghost Rider, the pattern is full:
>
> dkr...@logos:~/radiant> rake radiant:gem
> (in /Users/dkreft/radiant)
> rake aborted!
> Malformed version number string 0.9.0.rc3
> /Users/dkreft/radiant/Rakefile:7
> (See full trace by running task with --trace)
>
>          dkr...@logos:~/radiant> rake --version
>          rake, version 0.7.3
> -dan
> On Wed, May 19, 2010 at 2:05 PM, john muhl <johnm...@gmail.com> wrote:
>>
>> you might have better luck with rake radiant:gem
>>
>> On Wed, May 19, 2010 at 3:56 PM, D.Kreft <d...@kreft.net> wrote:
>> > Thanks. Though now I have a different problem:
>> >
>> > % gem build radiant.gemspec
>> > ERROR:  While executing gem ... (ArgumentError)
>> >
>> >
>> >  /System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/lib/ruby/1.8/rubygems/version.rb:56:in
>> > `initialize': Malformed version number string 0.9.0.rc3
>> >
>> > Do I just need to get into the gemspec and hack the version number?
>> > -dan
>> > On Wed, May 19, 2010 at 1:39 PM, john muhl <johnm...@gmail.com> wrote:
>> >>
>> >> git submodule init
>> >> git submodule update
>> >>
>> >> On Wed, May 19, 2010 at 2:41 PM, D.Kreft <d...@kreft.net> wrote:
>> >> > I'm trying to build a gem for radiant-0.9.0.rc3, but it's not going
>> >> > too
>> >> > well. Is there some secret mojo I'm missing?
>> >> > % pwd
>> >> > /workplace/octane/src/RubyGem-radiant/radiant-0.9.0.rc3
>> >> > % gem build radiant.gemspec
>> >> > ERROR:  While executing gem ... (Gem::InvalidSpecificationException)
>> >> >     ["vendor/extensions/archive/app",
>> >> > "vendor/extensions/archive/app/models",
>> >> > "vendor/extensions/archive/app/models/archive_day_index_page.rb",
>> >> > "vendor/extensions/archive/app/models/archive_finder.rb",
>> >> > "vendor/extensions/archive/app/models/archive_month_index_page.rb",
>> >> > "vendor/extensions/archive/app/models/archive_page.rb",
>> >> > "vendor/extensions/archive/app/models/archive_year_index_page.rb",
>> >> > "vendor/extensions/archive/archive_extension.rb",
>> >> > "vendor/extensions/archive/lib",
>> >> > "vendor/extensions/archive/lib/archive_index_tags_and_methods.rb",
>> >> > "vendor/extensions/archive/lib/tasks",
>> >> > "vendor/extensions/archive/lib/tasks/archive_extension_tasks.rake",
>> >> > "vendor/extensions/archive/Rakefile",
>> >> > "vendor/extensions/archive/README",
>> >> > "vendor/extensions/archive/spec",
>> >> > "vendor/extensions/archive/spec/datasets",
>> >> > "vendor/extensions/archive/spec/datasets/archive_dataset.rb",
>> >> > "vendor/extensions/archive/spec/models",
>> >> >
>> >> > "vendor/extensions/archive/spec/models/archive_day_index_page_spec.rb",
>> >> >
>> >> >
>> >> > "vendor/extensions/archive/spec/models/archive_month_index_page_spec.rb",
>> >> > "vendor/extensions/archive/spec/models/archive_page_spec.rb",
>> >> >
>> >> > "vendor/extensions/archive/spec/models/archive_year_index_page_spec.rb",
>> >> > "vendor/extensions/archive/spec/spec.opts",
>> >> > "vendor/extensions/archive/spec/spec_helper.rb",
>> >> > "vendor/extensions/archive/test",
>> >> > "vendor/extensions/archive/test/fixtures",
>> >> > "vendor/extensions/archive/test/fixtures/pages.yml",
>> >> > "vendor/extensions/archive/test/functional",
>> >> >
>> >> > "vendor/extensions/archive/test/functional/archive_extension_test.rb",
>> >> > "vendor/extensions/archive/test/helpers",
>> >> >
>> >> > "vendor/extensions/archive/test/helpers/archive_index_test_helper.rb",
>> >> > "vendor/extensions/archive/test/test_helper.rb",
>> >> > "vendor/extensions/archive/test/unit",
>> >> > "vendor/extensions/archive/test/unit/archive_day_index_page_test.rb",
>> >> >
>> >> > "vendor/extensions/archive/test/unit/archive_month_index_page_test.rb",
>> >> > "vendor/extensions/archive/test/unit/archive_page_test.rb",
>> >> >
>> >> > "vendor/extensions/archive/test/unit/archive_year_index_page_test.rb",
>> >> > "vendor/extensions/dutch_language_pack/config",
>> >> > "vendor/extensions/dutch_language_pack/config/locales",
>> >> > "vendor/extensions/dutch_language_pack/config/locales/nl.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/dutch_language_pack/config/locales/nl_available_tags.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/dutch_language_pack/dutch_language_pack_extension.rb",
>> >> > "vendor/extensions/dutch_language_pack/lib",
>> >> > "vendor/extensions/dutch_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/dutch_language_pack/lib/tasks/i18n_nl_extension_tasks.rake",
>> >> > "vendor/extensions/dutch_language_pack/Rakefile",
>> >> > "vendor/extensions/dutch_language_pack/README",
>> >> > "vendor/extensions/french_language_pack/config",
>> >> > "vendor/extensions/french_language_pack/config/locales",
>> >> > "vendor/extensions/french_language_pack/config/locales/fr.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/french_language_pack/config/locales/fr_available_tags.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/french_language_pack/french_language_pack_extension.rb",
>> >> > "vendor/extensions/french_language_pack/lib",
>> >> > "vendor/extensions/french_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/french_language_pack/lib/tasks/i18n_fr_extension_tasks.rake",
>> >> > "vendor/extensions/french_language_pack/Rakefile",
>> >> > "vendor/extensions/french_language_pack/README",
>> >> > "vendor/extensions/german_language_pack/config",
>> >> > "vendor/extensions/german_language_pack/config/locales",
>> >> > "vendor/extensions/german_language_pack/config/locales/de.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/german_language_pack/config/locales/de_available_tags.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/german_language_pack/german_language_pack_extension.rb",
>> >> > "vendor/extensions/german_language_pack/lib",
>> >> > "vendor/extensions/german_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/german_language_pack/lib/tasks/i18n_de_extension_tasks.rake",
>> >> > "vendor/extensions/german_language_pack/Rakefile",
>> >> > "vendor/extensions/german_language_pack/README",
>> >> > "vendor/extensions/italian_language_pack/config",
>> >> > "vendor/extensions/italian_language_pack/config/locales",
>> >> > "vendor/extensions/italian_language_pack/config/locales/it.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/italian_language_pack/config/locales/it_available_tags.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/italian_language_pack/italian_language_pack_extension.rb",
>> >> > "vendor/extensions/italian_language_pack/lib",
>> >> > "vendor/extensions/italian_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/italian_language_pack/lib/tasks/i18n_it_extension_tasks.rake",
>> >> > "vendor/extensions/italian_language_pack/Rakefile",
>> >> > "vendor/extensions/italian_language_pack/README",
>> >> > "vendor/extensions/japanese_language_pack/config",
>> >> > "vendor/extensions/japanese_language_pack/config/locales",
>> >> > "vendor/extensions/japanese_language_pack/config/locales/ja.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/japanese_language_pack/config/locales/ja_available_tags.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/japanese_language_pack/japanese_language_pack_extension.rb",
>> >> > "vendor/extensions/japanese_language_pack/lib",
>> >> > "vendor/extensions/japanese_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/japanese_language_pack/lib/tasks/i18n_ja_extension_tasks.rake",
>> >> > "vendor/extensions/japanese_language_pack/Rakefile",
>> >> > "vendor/extensions/japanese_language_pack/README",
>> >> > "vendor/extensions/russian_language_pack/config",
>> >> > "vendor/extensions/russian_language_pack/config/locales",
>> >> > "vendor/extensions/russian_language_pack/config/locales/ru.yml",
>> >> >
>> >> >
>> >> > "vendor/extensions/russian_language_pack/config/locales/ru_available_tags.yml",
>> >> > "vendor/extensions/russian_language_pack/lib",
>> >> > "vendor/extensions/russian_language_pack/lib/tasks",
>> >> >
>> >> >
>> >> > "vendor/extensions/russian_language_pack/lib/tasks/i18n_ru_extension_tasks.rake",
>> >> > "vendor/extensions/russian_language_pack/Rakefile",
>> >> > "vendor/extensions/russian_language_pack/README",
>> >> >
>> >> >
>> >> > "vendor/extensions/russian_language_pack/russian_language_pack_extension.rb",
>> >> > "vendor/plugins/spec_integration", "vendor/plugins/vizres"] are not
>> >> > files
>> >> >
>> >
>> >
>
>

Reply via email to