On Mon, Jul 12, 2010 at 6:07 PM, William Ross <w...@spanner.org> wrote:

> On 12 Jul 2010, at 17:53, Matt Spendlove wrote:
> > anyone have thoughts on this?
> >
> > On Jul 8, 6:40 pm, Matt Spendlove <matt.spendl...@gmail.com> wrote:
> >> Hi all
> >>
> >> Bit confused, after upgrading a project to 0.9 I run : rake
> >> radiant:update to get the sass goodness.
> >> The project is under SVN and afterwards these dirs show as "switched" in
> SVN:
> >>
> >> /public/stylesheets/sass/admin/modules
> >> /public/stylesheets/sass/admin/partials
> >> I'm assuming the update task is copying the .svn meta data directories
> >> or something?
> The stylesheet and sass update tasks are the only ones that copy whole
> directories so yes, that is where I'd expect invisible files to show up.
> There aren't any .svn directories in radiant's git repository, but perhaps
> your local installation of radiant has SVN metadata in it that conflicts
> with the application you're updating?
I'm using 0.9 frozen into /vendor of the project dir that I'm working on and
that whole project tree is under svn. The negative impact is that I can't
commit the updated sass files back to svn once copied from the
vendor/radiant directory so my cap-deployed version on the server isn't the
same, unless I run the rake task again on the server. I tried a few things
but svn (and myself) seemed to be in a bit of a muddle. Im sure I can sort
this out but I guess from an end user perspective it's a little fussy? It's
quite likely that folk will have a vendored version of radiant under source
control right?

Yea I know, all the cool kids are using git but..


Reply via email to